Bug 16236 - Desktop is larger than display
Desktop is larger than display
Status: CLOSED DUPLICATE of bug 14792
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 20:53 UTC by o. meijer
Modified: 2012-07-01 10:31 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.32 ,33 ,34
Tree: Mainline
Regression: Yes


Attachments
print screen + logs (bug marked) (738.71 KB, application/x-gzip)
2010-06-16 20:57 UTC, o. meijer
Details
xrandr --verbose (1.15 KB, application/x-gzip)
2010-07-23 21:08 UTC, o. meijer
Details
screenshot of bug scaled x0.5 (674.03 KB, image/png)
2010-07-28 13:37 UTC, o. meijer
Details
output dmesg (120.17 KB, text/plain)
2010-07-28 14:14 UTC, o. meijer
Details
xorg.0.log (33.11 KB, text/plain)
2010-07-28 14:15 UTC, o. meijer
Details
output of lspci -vv (13.14 KB, text/plain)
2010-07-28 14:16 UTC, o. meijer
Details
patch tested on 2.6.33.7 en 2.6.24.4 (922 bytes, text/x-csrc)
2010-08-15 20:49 UTC, o. meijer
Details

Description o. meijer 2010-06-16 20:53:11 UTC
Distribution: Ubuntu Lucid

hardware HP ProBook 4510s (has HDMI)
Kernels without bug: 2.6.31
Kernels with bug 2.6.32, 2.6.33, 2.6.34-rc2 (including standard Ubuntu Lucid kernel)
Bug also occurs with KMS disabled
Driver i915
graphics  Intel 4500 GMA, display 1366x768

Description of bug

Sometimes the mouse pointer or windows seem to disappear at the left side of the screen after login or after CHVT

A print screen reveals the bug very clearly, see attachments (the mouse pointer is invisible, I only see the left image).

Executing xrandr (without any or with options) will cure the desktop

I attached a xorg.0 log and two snippets (bug is clear, marked yellow).

Could you supply a patch, if possible for kernel 2.6.32. I know how to patch and recompile a kernel.

If you need further information, please let me know, but I am not a Linux expert

Kind regards,

Otto Meijer
Comment 1 o. meijer 2010-06-16 20:57:27 UTC
Created attachment 26817 [details]
print screen + logs (bug marked)
Comment 2 Andrew Morton 2010-06-16 21:02:05 UTC
I marked this as a regression.
Comment 3 o. meijer 2010-06-16 21:07:03 UTC
Kernels with bug 2.6.32, 2.6.33, 2.6.34, 35-rc2 (including standard Ubuntu Lucid
kernel)
Comment 4 Jesse Barnes 2010-07-23 19:47:13 UTC
Can you attach or paste the output of xrandr --verbose when you see the bug?  It looks like X could be detecting a non-existent output and creating an extended desktop config for you, which would cause this issue.
Comment 5 o. meijer 2010-07-23 21:08:02 UTC
Created attachment 27228 [details]
xrandr --verbose
Comment 6 o. meijer 2010-07-23 21:09:50 UTC
Thank you Jesse Barnes, I have added an attachment

Best regards,

Otto Meijer
Comment 7 Jesse Barnes 2010-07-23 21:17:41 UTC
It's easier if you just attach the text files directly so I don't have to untar and such.

They look ok too, both indicate only LVDS1 is connected and has a mode on it.  The only real difference I see is the default fitting mode, but that should be irrelevant since you're running a native mode.

So it's possible this is an X configuration issue of some kind, have you tried the Xorg edgers repo for Ubuntu?
Comment 8 o. meijer 2010-07-24 17:17:25 UTC
Thank you again, I tried xorg edgers, either it does not help (more stable drivers) or it locks my computer. (breaks X). I think it could be a kernel issue as kernel 2.6.31.x works fine. 

Kind regards,

Otto Meijer
Comment 9 Chris Wilson 2010-07-24 17:38:18 UTC
(In reply to comment #8)
> Thank you again, I tried xorg edgers, either it does not help (more stable
> drivers) or it locks my computer. (breaks X).

Sorry, I am failing to parse that sentence. If it breaks, can you grab the debug information (dmesg, Xorg.0.log and i915_error_state) and upload it here as that may give more clues as to what is happening on your system.
Comment 10 o. meijer 2010-07-28 13:37:52 UTC
Created attachment 27282 [details]
screenshot of bug scaled x0.5
Comment 11 o. meijer 2010-07-28 13:39:27 UTC
Dear developers.
I attached again a screen shot. I cannot see gnome-terminal in the left right image. I see the left image only. Is it indeed not possible that X detects a non-existent output (comment 4). Executing xrandr --verbose cures the display. As kernel 2.6.31 works fine, I believed it is a kernel bug.

What can I do to track down the cause of the bug, and help to have it resolved.

Best regards,
Otto Meijer
Comment 12 Chris Wilson 2010-07-28 13:47:32 UTC
http://intellinuxgraphics.org/how_to_report_bug.html is the guide on how to gather the information we need.

What appears to be the problem here is that the initial probe is returning an incorrect layout. So we need the debug logs for that, preferably the boot dmesg with drm.debug=0x6 and Xorg.0.log.
Comment 13 o. meijer 2010-07-28 14:14:08 UTC
Created attachment 27288 [details]
output dmesg
Comment 14 o. meijer 2010-07-28 14:15:25 UTC
Created attachment 27289 [details]
xorg.0.log
Comment 15 o. meijer 2010-07-28 14:16:15 UTC
Created attachment 27290 [details]
output of lspci -vv
Comment 16 o. meijer 2010-07-28 14:21:09 UTC
CHVT 7 - CHVT1 - CHVT7 (Crtl F7, Crtl F1, Crtl F7) introduced the bug now, the attachments of comment 13, 14, 15 were created after this.

Please lat me know if the information is insufficient or if you need further information.

Otto Meijer
Comment 17 Chris Wilson 2010-07-28 15:52:14 UTC
Ho hum, another instance of a spurious TV detection:

[   32.064283] [drm:drm_helper_probe_single_connector_modes], SVIDEO-1
[   32.112203] [drm:intel_tv_detect_type], Detected S-Video TV connection
[   32.112221] [drm:drm_helper_probe_single_connector_modes], Probed modes for SVIDEO-1
[   32.112226] [drm:drm_mode_debug_printmodeline], Modeline 45:"848x480" 30 14513 848 849 912 944 480 481 512 513 0x48 0x0
[   32.112234] [drm:drm_mode_debug_printmodeline], Modeline 42:"640x480" 30 11315 640 641 704 736 480 481 512 513 0x48 0x0
[   32.112242] [drm:drm_mode_debug_printmodeline], Modeline 44:"1024x768" 30 26886 1024 1025 1088 1120 768 769 800 801 0x40 0x0
[   32.112250] [drm:drm_mode_debug_printmodeline], Modeline 43:"800x600" 30 16998 800 801 864 896 600 601 632 633 0x40 0x0
[   32.112275] [drm:drm_mode_getconnector], connector id 19:
Comment 18 Chris Wilson 2010-07-28 15:58:01 UTC
The Xorg.log doesn't explain why it allocates the framebuffer it does. Something else to fix.
Comment 19 o. meijer 2010-08-02 21:21:40 UTC
the bug is not fixed with kernel 2.6.35
Comment 20 o. meijer 2010-08-15 20:49:18 UTC
Created attachment 27455 [details]
patch tested on 2.6.33.7 en 2.6.24.4
Comment 21 o. meijer 2010-08-15 20:54:09 UTC
Dear developers,

I found this patch. It has never been included in the kernel but fixes the bug. I did not find any side effects. I hope that it can be included in the kernel soon. Please let me know if you need further information or testing.

Kind regards,

otto meijer
Comment 22 o. meijer 2010-11-17 11:13:29 UTC
Dear developers,

The bug is still not solved with kernel 2.6.27-rc2. How can I help to get this bug fixed?

The patch of commend 21 (tested on 2.6.35 and 2.6.26) fixes the issue. Please let me know if you need further information or testing.


Best regards,

Otto Meijer
Comment 23 o. meijer 2010-11-17 11:14:54 UTC
2.6.27-rc2 = 2.6.37-rc2
Comment 24 Joel Schaerer 2011-01-21 08:58:49 UTC
Any news on this bug? Any chance the patch will be merged soon? The bug has been bugging a few people at Arch, too: https://bugs.archlinux.org/task/19234
Comment 25 darkbasic 2011-02-02 14:54:57 UTC
I reported the same bug here: https://bugs.freedesktop.org//show_bug.cgi?id=27169
2.6.38 and drm-intel-fixes are still bugged.
Comment 26 o. meijer 2011-03-08 22:51:54 UTC
Dear developers,

Tested with kernels 3.6.35, 3.6.38 rc5

I found a simple workaround without patching the kernel. Odd, but adding "video=SVIDEO-1:d" as boot parameter in grub fixes the issue. Very strange as my laptop computer has no s-video connection.

I hope that the real cause of the bug can be tracked down and fixed.

Best regards,

Otto Meijer
Comment 27 darkbasic 2011-03-08 23:02:20 UTC
There is already a fix (https://bugs.freedesktop.org//show_bug.cgi?id=27169#c19) but for some reasons Eric Anholt told it was bad.
Comment 28 Daniel Vetter 2012-03-25 14:41:03 UTC
We've merged quite a few patches to fix up the TV detection logic. Please retest with 3.3 and if this problem still exist, reopen the bug.
Comment 29 darkbasic 2012-03-25 20:29:57 UTC
3.3 does not solve the problem, please merge the working fix (https://bugs.freedesktop.org//attachment.cgi?id=42814) before 3.4 window closes.

P.S.
I'm sorry but I don't know how to reopen the bug.
Comment 30 darkbasic 2012-03-27 13:50:05 UTC
Up! Daniel schedule this patch for -next and it should land on 3.5.
After more than two years we will finally put an end to the gm45 nightmare :)
Comment 31 Daniel Vetter 2012-03-27 14:06:32 UTC

*** This bug has been marked as a duplicate of bug 14792 ***
Comment 32 Florian Mickler 2012-07-01 09:41:41 UTC
A patch referencing this bug report has been merged in Linux v3.5-rc1:

commit d42c9e2c24f7e7897405b85816bdf4ac924881c0
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Sun Mar 25 22:56:14 2012 +0200

    drm/i915: reinstate GM45 TV detection fix

Note You need to log in before you can comment on or make changes to this bug.