Bug 16235 - [REGRESSION] [IWL3945] Broadcast is broken?
Summary: [REGRESSION] [IWL3945] Broadcast is broken?
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Reinette Chatre
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-06-16 20:24 UTC by Maciej Rutecki
Modified: 2010-07-08 22:51 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.35-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-16 20:24:15 UTC
Subject    : [REGRESSION] [IWL3945] Broadcast is broken?
Submitter  : Maciej Rutecki <maciej.rutecki@gmail.com>
Date       : 2010-06-14 17:24
Message-ID : 201006141924.24061.maciej.rutecki@gmail.com
References : http://marc.info/?l=linux-kernel&m=127653628301300&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 John W. Linville 2010-06-16 20:27:40 UTC
Patch in question is this...

commit 3474ad635db371b0d8d0ee40086f15d223d5b6a4
Author: Johannes Berg <johannes.berg@intel.com>
Date:   Thu Apr 29 04:43:05 2010 -0700

    iwlwifi: apply filter flags directly
    
    Since iwl_configure_filter can now sleep since
    the mac80211 callback was changed, we can now
    apply filter flags changes directly.
    
    Also, while at it, make the code a bit more
    generic with a local macro. There's no need
    to check changed_flags since we apply all at
    the same time anyway.
    
    Signed-off-by: Johannes Berg <johannes.berg@intel.com>
    Signed-off-by: Reinette Chatre <reinette.chatre@intel.com>
Comment 2 Reinette Chatre 2010-06-16 22:48:08 UTC
we will revert this patch in our next submission.
Comment 3 Rafael J. Wysocki 2010-06-21 18:48:01 UTC
On Monday, June 21, 2010, Berg, Johannes wrote:
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=16235
> > Subject             : [REGRESSION] [IWL3945] Broadcast is broken?
> > Submitter   : Maciej Rutecki <maciej.rutecki@gmail.com>
> > Date                : 2010-06-14 17:24 (7 days old)
> > Message-ID  : <201006141924.24061.maciej.rutecki@gmail.com>
> > References  : http://marc.info/?l=linux-kernel&m=127653628301300&w=2
> 
> I asked Maxim to test a patch, which he has, and am in the process of pushing
> it upstream.
Comment 5 Rafael J. Wysocki 2010-06-27 22:45:29 UTC
Fixed by commit 3474ad635db371b0d8d0ee40086f15d223d5b6a4 .
Comment 6 Maciej Rutecki 2010-07-05 20:44:01 UTC
On 2.6.35-rc4 bug still exists.
Comment 7 Reinette Chatre 2010-07-06 05:42:18 UTC
(In reply to comment #5)
> Fixed by commit 3474ad635db371b0d8d0ee40086f15d223d5b6a4 .

No - this is actually the commit that caused the problem in the first place.
Comment 8 Reinette Chatre 2010-07-06 05:43:45 UTC
(In reply to comment #6)
> On 2.6.35-rc4 bug still exists.

Looks like the fix did not make it into rc4. It is in net-2.6 though so will be picked up next time Linus merges from it.
Comment 9 Rafael J. Wysocki 2010-07-06 18:44:31 UTC
Ignore-Patch : http://git.kernel.org/?p=linux/kernel/git/iwlwifi/iwlwifi-2.6.git;a=commit;h=4d23e4e5eb50431426facf192354ad2506e2dd40

Can anyone please post a correct link to the patch?
Comment 10 Reinette Chatre 2010-07-06 19:00:45 UTC
(In reply to comment #9)
> Ignore-Patch :
>
> http://git.kernel.org/?p=linux/kernel/git/iwlwifi/iwlwifi-2.6.git;a=commit;h=4d23e4e5eb50431426facf192354ad2506e2dd40
> 
> Can anyone please post a correct link to the patch?

This patch above is the correct link to the patch that fixes the issue. This patch is currently queued in net-2.6 as d1e89f37de2845db364ef6d67586cd882f86b557.

The commit id provided in comment #5 is a different patch and is the one that introduced the problem.
Comment 11 Rafael J. Wysocki 2010-07-08 22:51:51 UTC
Fixed by commit d1e89f37de2845db364ef6d67586cd882f86b557 .

Note You need to log in before you can comment on or make changes to this bug.