Bug 1622 - Dell PE4600 requires SCI w/ level polarity w/o override -- IO-APIC
Summary: Dell PE4600 requires SCI w/ level polarity w/o override -- IO-APIC
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Len Brown
URL:
Keywords:
: 1689 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-12-01 18:45 UTC by Shaohua
Modified: 2004-05-14 23:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.0-test9
Tree: Mainline
Regression: ---


Attachments
interrupt when SCI is edge (923 bytes, text/plain)
2003-12-01 22:32 UTC, Shaohua
Details
interrupt when SCI is level (923 bytes, text/plain)
2003-12-01 22:33 UTC, Shaohua
Details
dmesg when SCI is edge (26.03 KB, text/plain)
2003-12-01 22:34 UTC, Shaohua
Details
dmesg when SCI is level (26.09 KB, text/plain)
2003-12-01 22:35 UTC, Shaohua
Details
acpidmp (95.55 KB, text/plain)
2003-12-01 23:22 UTC, Shaohua
Details
Dmesg on SCB2 system, which exhibits the same problem (17.33 KB, text/plain)
2004-02-24 16:38 UTC, Andy Grover
Details
i386 patch on top of linux-acpi-test-2.6.4 tree (10.30 KB, patch)
2004-03-21 23:45 UTC, Len Brown
Details | Diff
updated i386 patch handles non-identity mappings (10.43 KB, patch)
2004-03-22 13:12 UTC, Len Brown
Details | Diff

Description Shaohua 2003-12-01 18:45:57 UTC
Distribution:
Hardware Environment:
Dell poweredge 3600


Steps to reproduce:
the box lacks SCI overriding. Current code will set SCI to edge state in the 
box. But SCI must be level in the box.
related Bug:Bug 774
Comment 1 Shaohua 2003-12-01 18:54:01 UTC
if we set default SCI polarity to edge, my box will break. if verbose, Tyan 
board(bug 774) will break.
Comment 2 Shaohua 2003-12-01 22:32:47 UTC
Created attachment 1587 [details]
interrupt when SCI is edge
Comment 3 Shaohua 2003-12-01 22:33:39 UTC
Created attachment 1588 [details]
interrupt when SCI is level
Comment 4 Shaohua 2003-12-01 22:34:29 UTC
Created attachment 1589 [details]
dmesg when SCI is edge
Comment 5 Shaohua 2003-12-01 22:35:11 UTC
Created attachment 1590 [details]
dmesg when SCI is level
Comment 6 Shaohua 2003-12-01 23:22:28 UTC
Created attachment 1593 [details]
acpidmp
Comment 7 Andy Grover 2004-02-24 16:38:08 UTC
Created attachment 2225 [details]
Dmesg on SCB2 system, which exhibits the same problem

This machine is why we added the SCI level force way back when. As you can see
it has no overrides for IRQ 9, but yet the SCI only works if it is forced level
low. One other note about this dmesg - the dswload warnings and the global lock
warnings are not the problem. We looked at these when the problem originally
came up.
Comment 8 Len Brown 2004-03-21 23:45:02 UTC
Created attachment 2384 [details]
i386 patch on top of linux-acpi-test-2.6.4 tree
Comment 9 Len Brown 2004-03-22 13:12:42 UTC
Created attachment 2388 [details]
updated i386 patch handles non-identity mappings
Comment 10 Len Brown 2004-03-22 22:38:47 UTC
2.6 patch to share i386/kernel/acpi/boot.c with x86_64, thus bringing that arch 
in sync with i386 and this fix: 
 
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/test/2.6.4/20040323013217-boot.c-x86_64.patch 
Comment 11 Len Brown 2004-03-23 01:44:36 UTC
i386 and x86_64 patch against 2.4.22: 
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/test/2.4.22/20040323042335-SCI.patch 
 
Comment 12 Len Brown 2004-04-12 20:58:40 UTC
in 2.4.26 and 2.6.5 -- closing. 
Comment 13 Len Brown 2004-05-14 23:12:59 UTC
*** Bug 1689 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.