Bug 16205 - acpi: freeing invalid memtype bf799000-bf79a000
acpi: freeing invalid memtype bf799000-bf79a000
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 16055 56331
  Show dependency treegraph
 
Reported: 2010-06-14 14:30 UTC by Maciej Rutecki
Modified: 2013-04-09 06:23 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-14 14:30:59 UTC
Subject    : acpi: freeing invalid memtype bf799000-bf79a000
Submitter  : Marcin Slusarz <marcin.slusarz@gmail.com>
Date       : 2010-06-09 20:09
Message-ID : 20100609200910.GA2876@joi.lan
References : http://marc.info/?l=linux-kernel&m=127611427029914&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dan Carpenter 2010-06-17 14:07:15 UTC
I mailed you a patch for this.  Could you give it a whirl?

http://marc.info/?l=linux-kernel&m=127678282429136&w=2
Comment 2 Zhang Rui 2010-06-21 07:54:04 UTC
ping...
Comment 3 Dan Carpenter 2010-06-21 08:30:37 UTC
Sorry, my patch wasn't right.  Xiaotian Feng is working on this.  The latest email was this:  http://marc.info/?l=linux-kernel&m=127688398513862&w=2

I should have CC'd bugzilla, but I'm not sure how to do that.
Comment 4 Rafael J. Wysocki 2010-06-21 18:17:11 UTC
References : http://marc.info/?l=linux-kernel&m=127688398513862&w=2
Comment 5 Zhang Rui 2010-06-30 08:10:18 UTC
re-assign it to MM category.
Comment 6 Marcin Slusarz 2010-07-09 15:49:58 UTC
fixed by b945d6b2554d550fe95caadc61e521c0ad71fb9c (rbtree: Undo augmented trees performance damage and regression) and 6a4f3b523779b67e7d560ed42652f8a59f2f9782 (x86, pat: Proper init of memtype subtree_max_end) combo
Comment 7 Rafael J. Wysocki 2010-07-09 20:36:34 UTC
Thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.