Bug 16199 - 2.6.35-rc2-git1 - include/linux/cgroup.h:534 invoked rcu_dereference_check() without protection!
Summary: 2.6.35-rc2-git1 - include/linux/cgroup.h:534 invoked rcu_dereference_check() ...
Status: CLOSED CODE_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Scheduler (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Ingo Molnar
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-06-13 19:53 UTC by Maciej Rutecki
Modified: 2010-07-09 21:30 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc2-git1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-13 19:53:50 UTC
Subject    : 2.6.35-rc2-git1 - include/linux/cgroup.h:534 invoked rcu_dereference_check() without protection!
Submitter  : Miles Lane <miles.lane@gmail.com>
Date       : 2010-06-07 18:14
Message-ID : AANLkTin2pPqOUx--9fIX3BH3e-cU6oCRufijcx_4ozx5@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=127593447812015&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-07-09 21:28:33 UTC
Fixed by commit dc61b1d6 ("sched: Fix PROVE_RCU vs cpu_cgroup").

Note You need to log in before you can comment on or make changes to this bug.