Bug 16197 - [BUG on 2.6.35-rc2] sysfs: cannot create duplicate filename '/devices/pci0000:00/0000:00:11.0/0000:02:03.0/slot'
[BUG on 2.6.35-rc2] sysfs: cannot create duplicate filename '/devices/pci0000...
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: SysFS
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 16055
  Show dependency treegraph
 
Reported: 2010-06-13 19:26 UTC by Maciej Rutecki
Modified: 2010-07-09 20:54 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.35-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-13 19:26:50 UTC
Subject    : [BUG on 2.6.35-rc2] sysfs: cannot create duplicate filename '/devices/pci0000:00/0000:00:11.0/0000:02:03.0/slot'
Submitter  : Ryan Wang <openspace.wang@gmail.com>
Date       : 2010-06-07 0:23
Message-ID : AANLkTincwMZPnYW3S4uz4k2GOn52RpgBIBRfzyD010Yo@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=127587022219378&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dan Carpenter 2010-06-18 22:00:48 UTC
This was fix already I believe.

commit 3be434f0244ee059432f92de7e891ee514f41738
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Fri Jun 11 13:08:37 2010 -0700

    Revert "PCI: create function symlinks in /sys/bus/pci/slots/N/"
    
    This reverts commit 75568f8094eb0333e9c2109b23cbc8b82d318a3c.
    
    Since they're just a convenience anyway, remove these symlinks since
    they're causing duplicate filename errors in the wild.
    
    Acked-by: Alex Chiang <achiang@canonical.com>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>

Note You need to log in before you can comment on or make changes to this bug.