Bug 1619 - poweroff unless no LAPIC
poweroff unless no LAPIC
Status: REJECTED DUPLICATE of bug 3238
Product: ACPI
Classification: Unclassified
Component: Power-Off
i386 Linux
: P2 normal
Assigned To: Len Brown
:
: 1658 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 05:20 UTC by Jan Bernatik
Modified: 2004-11-05 22:15 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.4.23-rc2 and newer
Tree: Mainline
Regression: ---


Attachments
shutdown LAPIC at poweroff (1.80 KB, patch)
2004-10-20 02:22 UTC, Alexey Starikovskiy
Details | Diff

Description Jan Bernatik 2003-12-01 05:20:56 UTC
Distribution: Debian stable 
 
hardware: 
centrino laptop (4-months old) 
pentium-M, intel 855PM chipset 
phoenix bios (could't found any real information at support), but maual to laptop says "BIOS 
corresponding to ACPI". 
 
description: 
with upgrade from 2.4.23-rc1 to rc2, after "power off", monitor is switched off, hdd semms to be 
switched off too, but leds indicating "power on" are still "shining", and fan is working. 
I have to swith laptop manually and then turn it on again. 
I have to use acpi="force" boot option 
This is same with 2.6.0-testX kernels. 
 
files: -------------------------------- 
 
.config (same rc1 & rc2) 
http://jaja.kn.vutbr.cz/~bernatik/kernel/config 
 
dmesg rc1 kernel (with acpi="force") 
http://jaja.kn.vutbr.cz/~bernatik/kernel/dmesg-rc1 
 
dmesg rc2 kernel (with acpi="force") 
http://jaja.kn.vutbr.cz/~bernatik/kernel/dmesg-rc2-with-acpi 
 
dmesg rc2 kernel (without acpi="force") 
http://jaja.kn.vutbr.cz/~bernatik/kernel/dmesg-rc2-without-acpi 
 
acpidmp rc1 kernel 
http://jaja.kn.vutbr.cz/~bernatik/kernel/acpidmp-rc1 
 
acpidmp rc2 kernel 
http://jaja.kn.vutbr.cz/~bernatik/kernel/acpidmp-rc2 
 
acpidmp rc2 kernel ( without acpi="force") (quite surprised me) 
http://jaja.kn.vutbr.cz/~bernatik/kernel/acpidmp-rc2-without-acpi
Comment 1 Len Brown 2003-12-01 23:34:30 UTC
Poweroff worked in rc1, but doesn't work in rc2?  Still broken in latest 2.4.23? 
Same BIOS version?  Same devices attached and modules loaded? 
What versions of 2.6 have you tried -- they all fail? 
 
Do you get to see the last messages on the screen before it is disabled? 
 
Please revert this patch 
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/test/2.4.22/20031117221510-poweroff.patch 
$ patch -Rp1 <tmp.patch 
and let me know if poweroff starts working again. 
 
> ACPI disabled because your bios is from 92 and too old  
 
Unusual. 
Please attach the output from dmidecode, available in /usr/sbin/, or here:  
http://www.nongnu.org/dmidecode/  
 
FYI, acpidmp reads the BIOS tables, so it doesn't change when booting the same config with 
different kernels. 
 
thanks, 
-Len 
 
Comment 2 Jan Bernatik 2003-12-02 03:06:38 UTC
yes, rc1 works, rc2 don't. in stable 2.4.23 don't.  
Same BIOS. Same devices & modules (none) 
As I remember, from test4 I tried I think all with same efect. 
If you want, I can try all test kernels if it is important. 
Last message I see on konsole is  
"unmounting local filesystem" 
and then monitor is switched off. 
 
with this patch rc2 works. 
 
dmidecode output: 
http://jaja.kn.vutbr.cz/~bernatik/kernel/dmidecode 
 
thanks for info and help. 
H. 
 
Comment 3 Len Brown 2003-12-02 10:11:26 UTC
Thanks for testing that 2.4.23 poweroff works with the patch reverted. 
Unfortunately, we got reports it _fixes_ poweroff for other machines... 
Looks like we need to debug it on your box if you're willing to apply 
some debug patches. 
 
Thanks for the dmidecode.  Looks like the vendor indeed toasted the date. 
 
        BIOS Information 
                Vendor: Phoenix Technologies LTD 
                Version: 4.06 
                Release Date: 01/01/92 
 
Since it is a new platform they're probably still updating the BIOS and if you report the bug they 
may fix it. 
 
Comment 4 Jan Bernatik 2003-12-02 13:17:43 UTC
sure I will test patches on my box. Sorry I can't do more for that moment . 
 
I don't understand if the bug in bios is just release date, or more. 
I can't believe the bios is from 92 ( it has for example boot from usb option ...) 
I already asked vendor to provide  some sdditional information. 
 
 
Comment 5 Jan Bernatik 2004-01-13 01:52:50 UTC
With the newest BIOS I don't have to use acpi="force" option anymore, vendor (surprisingly) repaired 
the BIOS release date. Anyway poweroff problem is still present :( 
Comment 6 Luming Yu 2004-01-13 02:03:54 UTC
There are some successful stoies on http://bugzilla.kernel.org/show_bug.cgi?
id=1141
Comment 7 Moshe Caspi 2004-04-15 03:59:20 UTC
Same problem on an old machine/bios using APM. 
Comment 8 Alexey Starikovskiy 2004-10-20 02:22:16 UTC
Created attachment 3860 [details]
shutdown LAPIC at poweroff 

Could you please try the following patch? It looks like forcefully enabled APIC

should be disabled before power off...
Comment 9 Jan Bernatik 2004-10-20 08:05:48 UTC
I tried to recompile 2.6.8.1 kernel without CONFIG_X86_UP_APIC, and the problem 
is gone. so I suppose it's solved. do you want me to try to apply the patch 
anyway ? 
 
Jan 
Comment 10 Alexey Starikovskiy 2004-10-21 00:45:39 UTC
Actually there are command string options to kernel to switch lapic off
("nolapic"). Bug is that linux should not hang without any twists... So this patch 
(or some other) is needed. On my Dell D600 this patch solved similar problem and
I hope it will work for you too. Thanks in advance.
Comment 11 Shaohua 2004-10-21 17:30:11 UTC
*** Bug 1658 has been marked as a duplicate of this bug. ***
Comment 12 Len Brown 2004-11-05 22:15:13 UTC
> Local APIC disabled by BIOS -- reenabling.
> Found and enabled local APIC!

Ah yes, duplicate of bug 3238

*** This bug has been marked as a duplicate of 3238 ***

Note You need to log in before you can comment on or make changes to this bug.