Bug 16180 - radeon regression with 2.6.35-rc2-00001-g386f40c: black screen after resume
Summary: radeon regression with 2.6.35-rc2-00001-g386f40c: black screen after resume
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks: 7216 16055
  Show dependency tree
 
Reported: 2010-06-11 10:59 UTC by cedric
Modified: 2010-07-08 22:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.35-rc
Tree: Mainline
Regression: Yes


Attachments
patch that put dpms on (858 bytes, patch)
2010-06-11 11:03 UTC, cedric
Details | Diff
Patch with a description and s-o-b (1022 bytes, patch)
2010-06-11 18:24 UTC, cedric
Details | Diff

Description cedric 2010-06-11 10:59:23 UTC
With the aforementioned kernel version, after a resume the screen stays black. Everything seems responding (wifi led blinking, reboot, ...).

After reading the logs between this kernel and 2.6.35-rc1-00194-gaef4b9a (known good), i think the problem is with this patch

drm/radeon/kms: make sure display hw is disabled when suspending

After I did apply the attached patch, the resume seems OK.
Don't know if it's the good solution...
Comment 1 cedric 2010-06-11 11:03:12 UTC
Created attachment 26725 [details]
patch that put dpms on
Comment 2 Alex Deucher 2010-06-11 16:06:18 UTC
Patch looks good.  Can you add your Signed-Off-By?
Comment 3 cedric 2010-06-11 18:24:18 UTC
Created attachment 26733 [details]
Patch with a description and s-o-b

Is this ok like this, I'm new at this thing (I'm just a poor tester/reporter ;-)
Comment 4 Alex Deucher 2010-06-11 18:41:22 UTC
Thanks.  I've sent the patch to Dave.
Comment 5 Rafael J. Wysocki 2010-06-14 20:02:01 UTC
Handled-By : Cedric Godin <cedric.godin@skynet.be>
Patch : https://bugzilla.kernel.org/attachment.cgi?id=26733

Note You need to log in before you can comment on or make changes to this bug.