Bug 16172 - 2.6.25-rc1 ahci regression
Summary: 2.6.25-rc1 ahci regression
Status: CLOSED INVALID
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jeff Garzik
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-06-09 19:35 UTC by Maciej Rutecki
Modified: 2010-06-23 21:20 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-09 19:35:31 UTC
Subject    : 2.6.25-rc1 ahci regression
Submitter  : Luming Yu <luming.yu@gmail.com>
Date       : 2010-06-03 7:02
Message-ID : AANLkTikWak8i-Kaj-e-EUFWE66tfMmp2UPhGJCKkK1zK@mail.gmail.com>
References : http://marc.info/?l=linux-kernel&m=127554855724361&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 365cfa1ed5a36f9bcb9f64c9f0f52155af2e9fef
Author: Anton Vorontsov <avorontsov@ru.mvista.com>
Date:   Sun Mar 28 00:22:14 2010 -0400

    ahci: Move generic code into libahci

    This patch should contain no functional changes, just moves code
    around.

    Signed-off-by: Anton Vorontsov <avorontsov@ru.mvista.com>
    Signed-off-by: Jeff Garzik <jgarzik@redhat.com>

First-Bad-Commit : 365cfa1ed5a36f9bcb9f64c9f0f52155af2e9fef
Comment 1 Jeff Garzik 2010-06-09 19:46:32 UTC
As noted in the linked thread, this problem is caused by the ahci driver not being loaded -- not anything the driver itself is doing.

It sounds like the problem lies with dracut, or whatever is loading the kernel modules.

Note You need to log in before you can comment on or make changes to this bug.