Bug 16169 - Complain from preemptive debug
Summary: Complain from preemptive debug
Status: CLOSED CODE_FIX
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpufreq (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: cpufreq
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-06-09 09:19 UTC by Rafael J. Wysocki
Modified: 2010-07-09 20:31 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.35-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-06-09 09:19:42 UTC
Subject    : [FIXED] 2.6.35-rc1: Call trace: BUG: using smp_processor_id() in preemptible [00000000]
Submitter  : Sedat Dilek <sedat.dilek@googlemail.com>
Date       : 2010-05-31 10:10
Message-ID : AANLkTilTnAAZIizKinYsxFkNTkrmPqk6XJJuUjjhJ7EP@mail.gmail.com
References : http://lkml.org/lkml/2010/5/31/77
Handled-By : Dmitry Monakhov <dmonakhov@openvz.org>
Patch      : http://www.spinics.net/lists/cpufreq/msg01631.html

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Sedat Dilek 2010-06-21 00:11:58 UTC
Andrew has an alternative patch [1] for this, it's not merged mainline.

- Sedat -

[1] https://patchwork.kernel.org/patch/106555/
Comment 2 Rafael J. Wysocki 2010-06-21 18:04:42 UTC
Handled-By : Sergey Senozhatsky <sergey.senozhatsky@gmail.com>
Patch : https://patchwork.kernel.org/patch/106555/
Comment 3 Sedat Dilek 2010-07-09 00:20:28 UTC
This bug is fixed Upstream [1]:

commit 8c215bd3890c347dfb6a2db4779755f8b9c298a9
"sched: Cure nr_iowait_cpu() users"

- Sedat -

[1] http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=8c215bd3890c347dfb6a2db4779755f8b9c298a9

Note You need to log in before you can comment on or make changes to this bug.