Bug 16149 - VGA display is off: blame commit "drm/i915: Don't enable pipe/plane/VCO early (wait for DPMS on)."
VGA display is off: blame commit "drm/i915: Don't enable pipe/plane/VCO early...
Status: CLOSED DUPLICATE of bug 16163
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 17:33 UTC by Giacomo Catenazzi
Modified: 2010-06-09 08:41 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Giacomo Catenazzi 2010-06-07 17:33:08 UTC
This commit cfecde435dda78248d6fcdc424bed68d5db6be0b "drm/i915: Don't enable pipe/plane/VCO early (wait for DPMS on)" causes the display of my primary monitor to remain off.

setup:
00:02.1 Display controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)
Main screen is VGA1, and a secondary screen is DVI1, and usually off (note: different screen resolutions).

In 2.6.34 (and before): kernel boots, VGA1 (and DVI1) displays the kernel and init.d messanges, than kdm starts X.

In early post 2.6.34 tree: kernel boots, screen go off (monitor show a "no signal" warning), but when kdm is started, it will display correctly the login screen.

After the commit cfecde435dda78248d6fcdc424bed68d5db6be0b: kernel boots, screen go off, and X starts but without displaying anythings in VGA1. Also after playing with xrandr.

[Note: sometime also on earlier kernel, when screen after screen going to suspend, sometime VGA1 monitor warn about wrong signals (frequency). But in this case xrandr off and on solve the problem.]

ciao
    cate
Comment 1 Giacomo Catenazzi 2010-06-07 17:35:02 UTC
oops: correct kernel version 2.6.35-rc1
Comment 2 Alex Villacis Lasso 2010-06-07 20:04:56 UTC
Also affected by the bug. 2.6.35-rc2
Comment 3 Alex Villacis Lasso 2010-06-07 21:10:50 UTC
I have confirmed that reverting cfecde435dda78248d6fcdc424bed68d5db6be0b fixes this particular bug and gives me a working display on 2.6.35-rc2.
Comment 4 Giacomo Catenazzi 2010-06-08 05:51:07 UTC
setting CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY also solve this (and additionally it show the console output before starting X),

But I'm confused. If system loads an other fb (see below my list), why:
#1 why Monitor booting the kernel say "No signal" (thus it detect the right video card).
#2 why starting X, without the above commit, the video is show at right resolution (so the fb is correct).

ciao
     cate

additional info of my configuration:
X.Org X Server 1.7.7

cate@cateee ~/kernel/linux-2.6$ grep FB .config | grep -v '#'
CONFIG_FB=y
CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_VGA16=y
CONFIG_FB_VESA=y
CONFIG_FB_LE80578=y
CONFIG_FB_CARILLO_RANCH=y
Comment 5 Rafael J. Wysocki 2010-06-09 08:41:01 UTC

*** This bug has been marked as a duplicate of bug 16163 ***

Note You need to log in before you can comment on or make changes to this bug.