Bug 16146 - Alps DualPoint touchpad on Dell Latitude E6510 not recognized
Alps DualPoint touchpad on Dell Latitude E6510 not recognized
Status: RESOLVED DUPLICATE of bug 14660
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 14:53 UTC by Derek P. Moore
Modified: 2010-06-08 18:35 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33.5
Tree: Mainline
Regression: No


Attachments

Description Derek P. Moore 2010-06-07 14:53:19 UTC
I'm having a problem similar to bug #13134.  My DualPoint trackball & touchpad work, but they are not recognized as Alps (they are recognized as "PS/2 Generic").  Without recognition, scrolling does not work, but tapping does.

I checked 'drivers/input/mouse/alps.c' & have confirmed that it is missing my device's bus/vendor/product ID triplet:

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input7
U: Uniq=
H: Handlers=mouse2 event7 
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

I'm proactively compiling a kernel based on Linus' kernel tree with my device's ID triplet included in 'alps.c'.  I'll update this ticket once I've been able to boot into that kernel for testing.

The trackball has 3 buttons; the touchpad has 2 buttons with vertical & horizontal scroll indicators.
Comment 1 Derek P. Moore 2010-06-07 19:20:38 UTC
I have also submitted a bug downstream:
https://bugzilla.redhat.com/show_bug.cgi?id=601365

I've compiled a custom kernel to include my device ID triplet with byte mask
"0xf8, 0xf8" & flags "ALPS_PASS | ALPS_DUALPOINT", but that didn't enable
recognition.  I'll try other options & update this ticket & downstream ticket
upon success.
Comment 2 Dmitry Torokhov 2010-06-07 20:14:42 UTC
What signature does your touchpad report?
Comment 3 Derek P. Moore 2010-06-07 20:48:07 UTC
Good question.  I thought it was "0x11, 0x02, 0x01" as per above (I didn't include the entire output of /proc/bus/input/devices), but now I see that I'm wrong in that assumption.

How can I get these IDs?  I've checked lspci, lshal, dmesg, lsusb, etc.
Comment 4 Dmitry Torokhov 2010-06-08 08:24:04 UTC
They are not shown by default. Please change #undef DEBUG to #define DEBUG in drivers/input/mouse/alps.c, recompile the module, reload (or reboot) and look for E6 and E7 report data in dmesg.

Thanks.
Comment 5 Derek P. Moore 2010-06-08 18:07:09 UTC
alps.c: E6 report: 00 00 64
alps.c: E7 report: 73 02 64
Comment 6 Dmitry Torokhov 2010-06-08 18:35:17 UTC
Unfortunately the magic knock working for this model of the touchpad has not been discovered yet.

*** This bug has been marked as a duplicate of bug 14660 ***

Note You need to log in before you can comment on or make changes to this bug.