Bug 16139 - wait_even_interruptible_timeout(), signal, spin_lock() = system hang
wait_even_interruptible_timeout(), signal, spin_lock() = system hang
Status: RESOLVED OBSOLETE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-06-06 07:59 UTC by Maciej Rutecki
Modified: 2013-12-10 21:42 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-06 07:59:31 UTC
Subject    : wait_even_interruptible_timeout(), signal, spin_lock() = system hang
Submitter  : Shirish Pargaonkar <shirishpargaonkar@gmail.com>
Date       : 2010-05-28 16:44
Message-ID : AANLkTiliRFydAhxH2-Dp1RKuz6sq7vgWIcMvLMi68ftg@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=127506510328758&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Shirish Pargaonkar 2010-06-06 19:11:51 UTC
I do not think this problem has anything to do with cifs.

./fsstress -d /mnt/smb_c -l 0 -n 1000 -p 2 -r

where a samba share is mounted over /mnt/smb_c and I am using
wait_event_interruptible_timeout instead of wait_event_timeout
(have posted a patch on kernel vger and fsdevel vger mailing list).

If I kill one of the processes spawned by fsstress (kill -9 <pid>), system 
panics and there is a stack trace on the text mode console, sometimes it prints 
part of panic and freezes and sometimes it prints and scorlls but either way, 
it is hard to capture the data on the  text mode console and I could capture 
only some meaningful like I have listed below.
I can't ping the sytem at this point.

kernel panic - not syncing Fatal Exception in interrupt
pid: 0  comm: swapper Tainted : G D W 2.6.34-1-default-1 #3
Call Trace:
<IRQ> [0x81301c62] panic 0x73/0xfc
                   oops_end 0xc0/0xd0
                   do_general_protection

If I Ctrl C fsstress command, system freezes, nothing is printed on the text 
mode console but I can continue pinging the system.

Note You need to log in before you can comment on or make changes to this bug.