Bug 16138 - PCMCIA regression
PCMCIA regression
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCMCIA
All Linux
: P1 normal
Assigned To: linux-pcmcia
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-06-06 06:16 UTC by Maciej Rutecki
Modified: 2010-06-21 18:12 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments
[PATCH] pcmcia: avoid validate_cis failure on CIS override (1.09 KB, patch)
2010-06-07 16:35 UTC, Dominik Brodowski
Details | Diff

Description Maciej Rutecki 2010-06-06 06:16:59 UTC
Subject    : PCMCIA regression
Submitter  : Mikulas Patocka <mpatocka@redhat.com>
Date       : 2010-05-25 20:25
Message-ID : Pine.LNX.4.64.1005251619020.12278@hs20-bc2-1.build.redhat.com
References : http://marc.info/?l=linux-kernel&m=127481913909672&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dominik Brodowski 2010-06-06 07:14:26 UTC
Mikulas, have you had the chance to run the tests I mentioned on lkml already? If not, here are my comments again:

"
Does this warning appear during reume, or during some other "special" use
case? Also, does commit cc83b08fc791045ac197e6f4a030599bcd7100c5 solve this
issue? If not: Could you enable dynamic debug logging via

# mount debugfs
mount none -t debugfs /sys/kernel/debug/

# enable debug
echo "module pcmcia +p" > /sys/kernel/debug/dynamic_debug/control
echo "module pcmcia_core +p" > /sys/kernel/debug/dynamic_debug/control
echo "module yenta_socket +p" > /sys/kernel/debug/dynamic_debug/control

and send me the resulting log (which may be looong).
"
Comment 2 Dominik Brodowski 2010-06-07 16:35:23 UTC
Created attachment 26685 [details]
[PATCH] pcmcia: avoid validate_cis failure on CIS override
Comment 3 Dominik Brodowski 2010-06-07 16:35:47 UTC
Mikulas, could you check out this patch, please? Thanks!
Comment 4 Rafael J. Wysocki 2010-06-13 14:05:13 UTC
Handled-By : Dominik Brodowski <linux@brodo.de>
Patch : https://bugzilla.kernel.org/attachment.cgi?id=26685
Comment 5 Rafael J. Wysocki 2010-06-21 18:12:16 UTC
Fixed by commit b83156b52dd77979cc93bafc2283929532f6f7d0 .

Note You need to log in before you can comment on or make changes to this bug.