Bug 16136 - Linux 2.6.34 causes system lockup on Compaq Presario 2200 Laptop
Linux 2.6.34 causes system lockup on Compaq Presario 2200 Laptop
Status: CLOSED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: acpi_power-battery
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-06-06 05:57 UTC by Maciej Rutecki
Modified: 2010-06-14 19:07 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-06 05:57:58 UTC
Subject    : Linux 2.6.34 causes system lockup on Compaq Presario 2200 Laptop
Submitter  : Jeffrey Merkey <jeffmerkey@gmail.com>
Date       : 2010-05-27 18:08
Message-ID : AANLkTil6GGSoc8TpzRacr1LZBZS3ee3H1ejYDSqfdul4@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=127498375415689&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Zhang Rui 2010-06-07 07:22:02 UTC
please attach the acpidump of this laptops.
and attach the content of "grep . /proc/acpi/battery/*/*" when the battery status is "broken".
Comment 2 Rafael J. Wysocki 2010-06-12 21:37:56 UTC
On Saturday, June 12, 2010, Jeffrey Merkey wrote:
> Not Reliably Reproducable.  Looks like a firmware/hardware problem
> with an old laptop.
> 
> Jeff
> 
> On Fri, Jun 11, 2010 at 3:19 PM, Jeffrey Merkey <jeffmerkey@gmail.com> wrote:
> > On Fri, Jun 11, 2010 at 11:07 AM, Len Brown <lenb@kernel.org> wrote:
> >> On Fri, 11 Jun 2010, Jeffrey Merkey wrote:
> >>
> >>> Len,
> >>>
> >>> I am having trouble getting a trace of this because its down hard to
> >>> reproduce.  The reason is the lockup happens before I log into the
> >>> laptop.  i.e. I boot 2.6.34 and if I let the laptop just sit there is
> >>> happens.  If I log in and start doing work on it, it does not seem to
> >>> happen.  It's related to using the laptop on battery mode with the
> >>> charger removed.  I have a 2U appliance setup I am working on today
> >>> and this frees up the laptop to try to reproduce this.  The flaky
> >>> battery power misreporting was in fact accurate.  The battery in that
> >>> laptop is 6 years old and does have low power.  I am certain the
> >>> lockup if related though.  I will try to reproduce today and setup the
> >>> trace to run after boot.  I have had it sitting there for an  hour and
> >>> it has not reoccurred.  Let me try through today and if I cannot
> >>> reproduce, close the bug.
> >>
> >> Good to know, Jeff.
> >>
> >> One possibility is that the old battery is confusing
> >> the embedded controller -- possibly exposing a firmware bug.
> >> The EC, in turn, is fully capable of hanging the OS.
> >>
> >> If you *can* reproduce it, it may be interesting to bisect
> >> recent changes to drivers/acpi/ec.c
> >>
> >> Also, if you can reproduce it, it would be good to verify
> >> that the problem occurs only when the battery driver is loaded.
> >>
> >> thanks,
> >> -Len
> >>
> >>> > Please attach the output of acpidump here:
> >>> >
> >>> > https://bugzilla.kernel.org/show_bug.cgi?id=16136
> >>
> >> We could still use this output -- note that you can
> >> capture it at any time, independent of the failure,
> >> and independent of the kernel -- as it is simply
> >> a copy of the tables that the BIOS is exporting to Linux.
> >>
> >> thanks,
> >> -Len Brown, Intel Open Source Technology Center
> >>
> >
> > I can tell you for certain it does only happen when the battery driver
> > is loaded.  Still has not ocurred.  Just rebooted it 15 minutes ago --
> > trying again.
> >
> > Jeff

Note You need to log in before you can comment on or make changes to this bug.