Bug 16134 - 2.6.34 hard lock ppp/do_tty_hangup, regression
2.6.34 hard lock ppp/do_tty_hangup, regression
Status: CLOSED UNREPRODUCIBLE
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-06-06 05:36 UTC by Maciej Rutecki
Modified: 2010-06-14 14:30 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-06 05:36:55 UTC
Subject    : 2.6.34 hard lock ppp/do_tty_hangup, regression
Submitter  : Richard Zidlicky <rz@linux-m68k.org>
Date       : 2010-05-26 8:48
Message-ID : 20100526084811.GA5890@linux-m68k.org
References : http://marc.info/?l=linux-kernel&m=127486354023473&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Richard Zidlicky 2010-06-14 14:20:38 UTC
I can not reproduce it anymore no matter how hard I am trying. The only change that I am aware of is this patch which would appear rather unrelated but as it fixes a rather grave spinlock error I can not completely rule out interaction:

--- linux-2.6.34/drivers/media/dvb/siano/smscoreapi.c.rz        2010-06-03 21:58:11.000000000 +0200
+++ linux-2.6.34/drivers/media/dvb/siano/smscoreapi.c   2010-06-07 14:32:06.000000000 +0200
@@ -1100,31 +1100,26 @@
  *
  * @return pointer to descriptor on success, NULL on error.
  */
-struct smscore_buffer_t *smscore_getbuffer(struct smscore_device_t *coredev)
+
+struct smscore_buffer_t *get_entry(struct smscore_device_t *coredev)
 {
        struct smscore_buffer_t *cb = NULL;
        unsigned long flags;
 
-       DEFINE_WAIT(wait);
-
        spin_lock_irqsave(&coredev->bufferslock, flags);
-
-       /* This function must return a valid buffer, since the buffer list is
-        * finite, we check that there is an available buffer, if not, we wait
-        * until such buffer become available.
-        */
-
-       prepare_to_wait(&coredev->buffer_mng_waitq, &wait, TASK_INTERRUPTIBLE);
-
-       if (list_empty(&coredev->buffers))
-               schedule();
-
-       finish_wait(&coredev->buffer_mng_waitq, &wait);
-
+       if (!list_empty(&coredev->buffers)) {
        cb = (struct smscore_buffer_t *) coredev->buffers.next;
        list_del(&cb->entry);
-
+       }
        spin_unlock_irqrestore(&coredev->bufferslock, flags);
+       return cb;
+}
+
+struct smscore_buffer_t *smscore_getbuffer(struct smscore_device_t *coredev)
+{
+       struct smscore_buffer_t *cb = NULL;
+
+       wait_event(coredev->buffer_mng_waitq, (cb = get_entry(coredev)));
 
        return cb;
 }

Note You need to log in before you can comment on or make changes to this bug.