Bug 16040 - kacpid consumes ~40% of cpu all the time beginning with 2.6.34
kacpid consumes ~40% of cpu all the time beginning with 2.6.34
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Other
All Linux
: P1 high
Assigned To: acpi_other
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-05-24 07:32 UTC by Mehmet Giritli
Modified: 2010-06-27 21:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments
dmesg (41.30 KB, text/plain)
2010-05-24 07:32 UTC, Mehmet Giritli
Details
/sys/firmware/acpi/interrupts/* (3.78 KB, text/plain)
2010-05-24 10:09 UTC, Mehmet Giritli
Details
/sys/firmware/acpi/interrupts/* for 2.6.34 after resume (3.78 KB, text/plain)
2010-05-24 11:16 UTC, Mehmet Giritli
Details

Description Mehmet Giritli 2010-05-24 07:32:55 UTC
Created attachment 26515 [details]
dmesg

Hi,

I am attaching dmesg from my laptop (Toshiba A350-22Z) where I have kacpid consuming around 40% of my cpu continuously. This did not happen with any of the kernels prior to 2.6.34 before, it is the first time I am seeing such a thing on my laptop.

Please let me know of any further data that you might need.
Comment 1 Zhang Rui 2010-05-24 08:41:58 UTC
please attach the output of "grep . /sys/firmware/acpi/interrupts/*"
Comment 2 Mehmet Giritli 2010-05-24 10:09:16 UTC
Created attachment 26516 [details]
/sys/firmware/acpi/interrupts/*

required output attached
Comment 3 Mehmet Giritli 2010-05-24 11:16:20 UTC
Created attachment 26517 [details]
/sys/firmware/acpi/interrupts/* for 2.6.34 after resume

please disregard the previous attachment, which belonged to 2.6.33 kernel.

Also, I've come to realise that high cpu consumation of kacpid occurs only after a resume from a suspended state. I doesn't seem to occur at the initial startup.

New output attached, after resume when the problem occurs.
Comment 4 Rafael J. Wysocki 2010-05-24 18:21:36 UTC
I guess this is a duplicate of bug #15924.
Comment 5 Zhang Rui 2010-06-09 08:20:00 UTC
Mehmet,
please verify if this is a duplicate of bug #15924.
please verify if the patches at https://bugzilla.kernel.org/show_bug.cgi?id=15924#c45 helps.
Comment 6 Mehmet Giritli 2010-06-18 07:28:31 UTC
(In reply to comment #5)
> Mehmet,
> please verify if this is a duplicate of bug #15924.
> please verify if the patches at
> https://bugzilla.kernel.org/show_bug.cgi?id=15924#c45 helps.

Sorry for the late reply.

I applied patch from comment 62 in that bug (seemed more conclusive than the previous patches) but it made no difference. Do you want me to try patches in comment 45 as well?

PS: I applied the patch against 2.6.34.
Comment 7 Zhang Rui 2010-06-18 07:44:15 UTC
yes, the patch in comment #62 is for another issue.
so please try the patches at comment #45.
Comment 8 Mehmet Giritli 2010-06-18 09:19:11 UTC
(In reply to comment #7)
> yes, the patch in comment #62 is for another issue.
> so please try the patches at comment #45.

Hi,

2. patch fails as follows:

patching file drivers/acpi/acpica/hwgpe.c
patching file drivers/acpi/acpica/achware.h
patching file drivers/acpi/acpica/evgpe.c
Hunk #1 FAILED at 99.
Hunk #2 FAILED at 350.
Hunk #3 succeeded at 440 with fuzz 1 (offset -62 lines).
Hunk #4 succeeded at 474 with fuzz 2 (offset -65 lines).
2 out of 4 hunks FAILED -- saving rejects to file drivers/acpi/acpica/evgpe.c.rej
patching file drivers/acpi/acpica/evxfevnt.c
Hunk #1 succeeded at 201 with fuzz 1 (offset -9 lines).
Hunk #2 succeeded at 273 (offset -14 lines).
Hunk #3 FAILED at 340.
Hunk #4 FAILED at 371.
Hunk #5 FAILED at 431.
Hunk #6 FAILED at 457.
4 out of 6 hunks FAILED -- saving rejects to file drivers/acpi/acpica/evxfevnt.c.rej
patching file include/acpi/actypes.h
Hunk #1 FAILED at 663.
1 out of 1 hunk FAILED -- saving rejects to file include/acpi/actypes.h.rej
patching file drivers/acpi/acpica/acevents.h
Hunk #1 succeeded at 78 (offset -2 lines).
patching file drivers/acpi/acpica/evxface.c
Hunk #1 FAILED at 721.
1 out of 1 hunk FAILED -- saving rejects to file drivers/acpi/acpica/evxface.c.rej

on 2.6.34 stable. The rest are fine. Now compile kernel fails due to failed patch perhaps...

Do I need unstable 2.6.35 from git?
Comment 9 Mehmet Giritli 2010-06-18 10:02:02 UTC
Ok. patches applied cleanly on 2.6.35 git and the problem is not there anymore.

Note You need to log in before you can comment on or make changes to this bug.