Bug 16038 - vga_switcheroo: kernel hang after OFF/ON after resume from pm-suspend
Summary: vga_switcheroo: kernel hang after OFF/ON after resume from pm-suspend
Status: RESOLVED DUPLICATE of bug 15845
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-23 20:20 UTC by Stefan Huber
Modified: 2010-05-23 20:23 UTC (History)
0 users

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: No


Attachments

Description Stefan Huber 2010-05-23 20:20:30 UTC
The following procedure leads to a hang of the kernel:
1. echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch
   to switch off the discrete adapter.
2. pm-suspend
3. resuming...
4. Power consumption indicates that both cards are powered but
      cat /sys/kernel/debug/vgaswitcheroo/switch

   claims that only the internal adapter is powered. As expected, calling
      echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch

   does not turn off the unused card. Anyhow, calling
      echo "ON" > /sys/kernel/debug/vgaswitcheroo/switch

   leads to a kernel hang.

No output to the console, hence no back trace is available here. However, if one suspends the notebook with both cards powered, it works well. That means, that one can turn off the discrete adapter after resuming without problems.

The system here is a Lenovo T400 with an Intel GMA X4500HD and a ATI Mobility Radeon HD 3470. Kernel version: gentoo-sources-2.6.34
Comment 1 Stefan Huber 2010-05-23 20:23:22 UTC

*** This bug has been marked as a duplicate of bug 15845 ***

Note You need to log in before you can comment on or make changes to this bug.