Bug 16037 - NULL Pointer dereference in __ir_input_register/budget_ci_attach
NULL Pointer dereference in __ir_input_register/budget_ci_attach
Status: CLOSED CODE_FIX
Product: v4l-dvb
Classification: Unclassified
Component: ttpci
All Linux
: P1 high
Assigned To: Mauro Carvalho Chehab
:
Depends on:
Blocks: 16055
  Show dependency treegraph
 
Reported: 2010-05-23 19:52 UTC by Sean Finney
Modified: 2010-06-09 08:59 UTC (History)
3 users (show)

See Also:
Kernel Version: v2.6.34-7098-g80050ff
Tree: Mainline
Regression: Yes


Attachments
the BUG() trace (3.99 KB, text/plain)
2010-05-23 19:52 UTC, Sean Finney
Details
lspci -v output (7.62 KB, text/plain)
2010-05-23 19:53 UTC, Sean Finney
Details

Description Sean Finney 2010-05-23 19:52:20 UTC
Created attachment 26511 [details]
the BUG() trace

Hi, it looks like the merge from fb091be08d1acf184e8801dfdcace6e0cb19b1fe has introduced a regression, when the ttpci module is loaded at boot up a get a kernel BUG() about null pointer derferencing.  info attached.

i've been riding latest from git for the past couple weeks but only saw this in the past week or so, so i'm strongly suspecting that it came from the above mentioned commit.  i believe others have seen this too:

http://article.gmane.org/gmane.linux.drivers.video-input-infrastructure/19494/match=
Comment 1 Sean Finney 2010-05-23 19:53:39 UTC
Created attachment 26512 [details]
lspci -v output
Comment 2 Mauro Carvalho Chehab 2010-06-09 02:20:47 UTC
Could you please check if this patch solves the issue?

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=84b14f181a36eea6591779156ef356f8d198bbfd
Comment 3 Sean Finney 2010-06-09 06:39:52 UTC
Hi Mauro,

I just pulled from the linux-2.6 remote (which has merged this commit), and no longer see the error.  

In fact I had just spent the last 15 minutes reviewing the merges since the last update and come to the same conclusion that it was probably this commit that had fixed it... so I say we consider it fixed unless heard otherwise from someone else :)

Note You need to log in before you can comment on or make changes to this bug.