Bug 16036 - _BCM doesn't work (writing to EC BLVL but no effect) - Toshiba T130
_BCM doesn't work (writing to EC BLVL but no effect) - Toshiba T130
Status: CLOSED DUPLICATE of bug 14216
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 blocking
Assigned To: Zhang Rui
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 19:10 UTC by Sven Rebhan
Modified: 2010-09-29 01:55 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: No


Attachments
acpidump (270.14 KB, application/octet-stream)
2010-05-23 19:10 UTC, Sven Rebhan
Details
lspci -v (9.13 KB, text/plain)
2010-05-24 17:27 UTC, Sven Rebhan
Details
dmesg for 2.6.34 boot (60.22 KB, text/plain)
2010-07-01 21:34 UTC, Sven Rebhan
Details
dmesg for 2.6.35 boot (64.83 KB, text/plain)
2010-07-01 21:34 UTC, Sven Rebhan
Details
config for 2.6.35 (67.78 KB, application/octet-stream)
2010-07-01 21:37 UTC, Sven Rebhan
Details

Description Sven Rebhan 2010-05-23 19:10:52 UTC
Created attachment 26510 [details]
acpidump

When changing brightness using xbacklight or e.g. echo "3" > /sys/class/backlight/acpi_video0/brightness the values in /sys/class/backlight/acpi_video0/actual_brightness and /proc/acpi change, but the actual backlight brightness does not change.

attaching acpidump
Comment 1 Sven Rebhan 2010-05-24 17:27:01 UTC
Created attachment 26530 [details]
lspci -v
Comment 2 Zhang Rui 2010-06-24 08:27:11 UTC
do you have a windows partition on this laptop?
If yes, it would be great if you can verify if the backlight control works in windows or not.
Comment 3 Sven Rebhan 2010-06-24 11:16:49 UTC
In windows I'm able to modify the brightness. Furthermore, the DSDT tables are exactly the same for Windows7 and Linux, if this is of any help to you. Please tell me if I can be of any help to solve this problem!
Comment 4 Zhang Rui 2010-06-30 08:25:21 UTC
are you using windows XP, Vista or win7?
Comment 5 Sven Rebhan 2010-06-30 11:27:57 UTC
I tried with windows 7.
Comment 6 Zhang Rui 2010-07-01 01:26:46 UTC
please rebuild the kernel with CONFIG_ACPI_WMI=y, and boot with acpi_backlight=vendor.
can the backlight work in this case?
Comment 7 Sven Rebhan 2010-07-01 21:33:29 UTC
The backlight also doesn't work with this setting in both kernel-2.6.34 and current 2.6.35 git (commit 980019d74e4b2428362b36a0506519d6d9460800). Both dmesg logs are attached along with the 2.6.35 config file.
Comment 8 Sven Rebhan 2010-07-01 21:34:17 UTC
Created attachment 26990 [details]
dmesg for 2.6.34 boot
Comment 9 Sven Rebhan 2010-07-01 21:34:47 UTC
Created attachment 26991 [details]
dmesg for 2.6.35 boot
Comment 10 Sven Rebhan 2010-07-01 21:37:07 UTC
Created attachment 26992 [details]
config for 2.6.35
Comment 11 Shavkat Nizamov 2010-09-07 06:00:09 UTC
Any progress here ? 

2.6.35 kernel (ubuntu): CONFIG_ACPI_WMI=y

booting with or without acpi_backlight=vendor   - backlight is not controllable. 

It worked before with "nomodeset acpi_backlight=vendor" (ubuntu 10.04 / kernel 2.6.32, xorg 1.7.6), but with newer xorg (1.9.0) it is not an option. 

Preinstalled win7 works OK.
Comment 12 Shavkat Nizamov 2010-09-08 05:12:46 UTC
Interesting, 
sudo setpci -s 00:02.0 F4.B=80 
like approach works anyway. Because it doesn't use ACPI ?
Comment 13 ykzhao 2010-09-20 07:23:35 UTC
Hi, Shavkat
    From the acpidump it seems that there exists the _BCM/_BCL/_BQC object. But after the _BCM object will write the requested brightness level to EC register, the brightness can't be changed. Maybe this is related with the BIOS.

    When writing the value to IGD PCI config space, it will write the IGD graphics backlight register. Maybe the incorrect ACPI backlight control mechanism is exported on this box. 

Thanks.
Comment 14 Zhang Rui 2010-09-27 01:14:11 UTC

*** This bug has been marked as a duplicate of bug 14216 ***

Note You need to log in before you can comment on or make changes to this bug.