Bug 16004 - Lenovo touch inductive SlideNav panel not work
Summary: Lenovo touch inductive SlideNav panel not work
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
: 43371 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-19 10:50 UTC by RussianNeuroMancer
Modified: 2015-02-19 15:48 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.2
Tree: Mainline
Regression: No


Attachments

Description RussianNeuroMancer 2010-05-19 10:50:27 UTC
Lenovo Yxx0 laptops have a touch inductive panel http://www.gigamark.com/images/stories/8/Lenovo_y550/Untitled-4.jpg contains the pretty cool navigation slidebar http://www.fcenter.ru/img/article/notebooks/Lenovo_IdeaPad_Y550P/152399.jpg
How SlideNav should work:
User assign applications to the numbers. When user want to launch one of them, they touch slidenav in any place (touch but did not raise finger), after that driver show applications list on the screen http://www.fcenter.ru/img/article/notebooks/Lenovo_IdeaPad_Y550P/152341.jpg User move finger to the lift or to the right, until needed application was selected on the screen. After apllication selected user raise finger and this application started.

I tried use tp-smapi-dkms for detect slidenav buttons, but it's not work for me with error: No such device.
Comment 1 Arnoques 2012-02-24 06:11:51 UTC
Hi,
I recently bought an Ideapad Y460p, and the SlideNav doesn't work with kernel 3.2.0 (I'm using Debian testing). A few touch buttons to the right of the SlideNav don't work either (I believe they are all part of the same thing).

I have very little experience compiling kernel modules, but I'm willing to learn whatever is needed to help you help me get this to work.

Thank you for all your hard work,
  Arnoques
Comment 2 Alan 2012-06-14 10:20:15 UTC
*** Bug 43371 has been marked as a duplicate of this bug. ***
Comment 3 Andrey Moiseev 2013-08-07 07:59:44 UTC
There is a discussion on this on Launchpad, the kernel driver for the slidebar is in testing: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/543119
Here is the kernel module, you can view it quickly: https://github.com/o2genum/ideapad-slidebar

Note You need to log in before you can comment on or make changes to this bug.