Bug 15996 - RT2860STA: WIFI encryption key is not updated when resume from suspend
RT2860STA: WIFI encryption key is not updated when resume from suspend
Status: CLOSED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Staging
All Linux
: P1 blocking
Assigned To: drivers_staging@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-05-18 13:19 UTC by Cijoml Cijomlovic Cijomlov
Modified: 2012-06-14 17:21 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: Yes


Attachments

Description Cijoml Cijomlovic Cijomlov 2010-05-18 13:19:50 UTC
Hello,

RT2860STA doesn't update it's encryption key (requested through wpa_supplicant) when resumed from suspend. In my previous kernel 2.6.32.X this worked everytime like a charm. 
Setting severity to BLOCKING because this caused my laptop not available at network after resume from suspend. 
Restart of network services made laptop available at network.
Comment 1 John W. Linville 2010-05-18 13:30:03 UTC
FWIW, drivers don't request keys -- wpa_supplicant decides when they need to be sent.
Comment 2 Andrew Morton 2010-05-20 21:43:03 UTC
But presumably this was caused by kernel changes - I assume the same userspace was used each time?
Comment 3 Cijoml Cijomlovic Cijomlov 2010-05-21 05:52:39 UTC
YES same userspace if I boot back to stable 2.6.32 kernel it works like a charm.
Comment 4 Cijoml Cijomlovic Cijomlov 2010-05-21 05:54:21 UTC
BTW with my second laptop with ipw2200 request after resume still work with 2.6.34
Comment 5 Rafael J. Wysocki 2010-06-13 13:45:14 UTC
Regressions in staging drivers are not listed any more.  Removing from the list.
Comment 6 Rafael J. Wysocki 2011-01-16 22:33:36 UTC
Is the problem still present in 2.6.37?
Comment 7 Cijoml Cijomlovic Cijomlov 2011-02-06 09:54:08 UTC
yes

Note You need to log in before you can comment on or make changes to this bug.