Bug 15981 - WARNING: at /home/kernel-ppa/mainline/build/net/wireless/mlme.c:341 cfg80211_send_assoc_timeout+0xa1/0x150 [cfg80211]()
Summary: WARNING: at /home/kernel-ppa/mainline/build/net/wireless/mlme.c:341 cfg80211_...
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
: 16110 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-16 00:36 UTC by Cristian Aravena Romero
Modified: 2011-01-18 22:15 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc1
Tree: Mainline
Regression: No


Attachments
$lspci -vv (13.62 KB, text/plain)
2010-05-16 00:38 UTC, Cristian Aravena Romero
Details
$dmesg_2.6.34-020634rc7-generic.log (60.45 KB, text/plain)
2010-05-16 00:39 UTC, Cristian Aravena Romero
Details
$dmesg_2.6.35-020635rc1-generic.log (69.16 KB, text/plain)
2010-06-05 18:29 UTC, Cristian Aravena Romero
Details

Description Cristian Aravena Romero 2010-05-16 00:36:23 UTC
[  859.355545] ------------[ cut here ]------------
[  859.355582] WARNING: at /home/kernel-ppa/mainline/build/net/wireless/mlme.c:341 cfg80211_send_assoc_timeout+0xa1/0x150 [cfg80211]()
[  859.355589] Hardware name: VGN-NS130FE
[  859.355593] Modules linked in: binfmt_misc ppdev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss arc4 snd_seq_midi snd_rawmidi joydev snd_seq_midi_event fbcon tileblit font bitblit softcursor snd_seq ath9k ath9k_common snd_timer snd_seq_device sdhci_pci sdhci snd mac80211 ath9k_hw i915 ath drm_kms_helper soundcore psmouse serio_raw cfg80211 uvcvideo led_class videodev v4l1_compat sony_laptop snd_page_alloc drm i2c_algo_bit video output intel_agp lp agpgart parport usbhid hid ohci1394 ieee1394 sky2 ahci
[  859.355692] Pid: 725, comm: phy0 Tainted: G        W  2.6.34-020634rc7-generic #020634rc7
[  859.355698] Call Trace:
[  859.355721]  [<f85c90a1>] ? cfg80211_send_assoc_timeout+0xa1/0x150 [cfg80211]
[  859.355734]  [<c014e621>] warn_slowpath_common+0x81/0xa0
[  859.355758]  [<f85c90a1>] ? cfg80211_send_assoc_timeout+0xa1/0x150 [cfg80211]
[  859.355766]  [<c014e65a>] warn_slowpath_null+0x1a/0x20
[  859.355790]  [<f85c90a1>] cfg80211_send_assoc_timeout+0xa1/0x150 [cfg80211]
[  859.355817]  [<f8e0d046>] ieee80211_assoc_done+0x66/0xa0 [mac80211]
[  859.355842]  [<f8e0eb4f>] ieee80211_work_work+0x1df/0x330 [mac80211]
[  859.355853]  [<c01664b9>] run_workqueue+0x89/0x140
[  859.355879]  [<f8e0e970>] ? ieee80211_work_work+0x0/0x330 [mac80211]
[  859.355887]  [<c0166927>] worker_thread+0x77/0xd0
[  859.355896]  [<c016a670>] ? autoremove_wake_function+0x0/0x40
[  859.355903]  [<c01668b0>] ? worker_thread+0x0/0xd0
[  859.355910]  [<c016a3e4>] kthread+0x74/0x80
[  859.355917]  [<c016a370>] ? kthread+0x0/0x80
[  859.355924]  [<c0103306>] kernel_thread_helper+0x6/0x10
[  859.355930] ---[ end trace a37a4141c85760a2 ]---
Comment 1 Cristian Aravena Romero 2010-05-16 00:38:44 UTC
Created attachment 26391 [details]
$lspci -vv
Comment 2 Cristian Aravena Romero 2010-05-16 00:39:24 UTC
Created attachment 26392 [details]
$dmesg_2.6.34-020634rc7-generic.log
Comment 3 Cristian Aravena Romero 2010-05-16 03:01:18 UTC
See bug #15794
Comment 4 John W. Linville 2010-05-17 20:06:21 UTC
Looks like we are timing-out on an association w/ a BSS with which we are not (any longer?) authenticated?
Comment 5 Cristian Aravena Romero 2010-05-18 20:22:22 UTC
I use WPA for authentication
Comment 6 Johannes Berg 2010-05-19 09:47:41 UTC
Hm. I thought this was fixed by 79733a865c7fd778ce45e3503962b3a875b0a153 but maybe not?
Comment 7 John W. Linville 2010-05-19 12:55:50 UTC
Ah, well -- that commit isn't in 2.6.34-rc7.  Cristian, can you recreate with 2.6.34 (or later)?
Comment 8 John W. Linville 2010-06-03 19:03:19 UTC
*** Bug 16110 has been marked as a duplicate of this bug. ***
Comment 9 Cristian Aravena Romero 2010-06-05 18:29:42 UTC
Created attachment 26662 [details]
$dmesg_2.6.35-020635rc1-generic.log

[ 2742.786426] ------------[ cut here ]------------
[ 2742.786453] WARNING: at /home/kernel-ppa/mainline/build/net/wireless/mlme.c:341 cfg80211_send_assoc_timeout+0x9f/0x150 [cfg80211]()
[ 2742.786456] Hardware name: VGN-NS130FE
[ 2742.786458] Modules linked in: binfmt_misc ppdev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss arc4 snd_pcm snd_seq_dummy snd_seq_oss joydev snd_seq_midi snd_rawmidi snd_seq_midi_event ath9k snd_seq ath9k_common snd_timer snd_seq_device snd ath9k_hw ath soundcore sdhci_pci mac80211 sdhci snd_page_alloc cfg80211 uvcvideo videodev v4l1_compat led_class psmouse serio_raw sony_laptop lp parport fbcon tileblit font bitblit softcursor i915 drm_kms_helper drm ohci1394 ahci ieee1394 sky2 libahci i2c_algo_bit intel_agp agpgart video output
[ 2742.786506] Pid: 952, comm: phy0 Not tainted 2.6.35-020635rc1-generic #020635rc1
[ 2742.786508] Call Trace:
[ 2742.786520]  [<f8bca8bf>] ? cfg80211_send_assoc_timeout+0x9f/0x150 [cfg80211]
[ 2742.786526]  [<c014ee61>] warn_slowpath_common+0x81/0xa0
[ 2742.786537]  [<f8bca8bf>] ? cfg80211_send_assoc_timeout+0x9f/0x150 [cfg80211]
[ 2742.786541]  [<c014eea2>] warn_slowpath_null+0x22/0x30
[ 2742.786552]  [<f8bca8bf>] cfg80211_send_assoc_timeout+0x9f/0x150 [cfg80211]
[ 2742.786567]  [<f8c38836>] ieee80211_assoc_done+0x66/0xa0 [mac80211]
[ 2742.786580]  [<f8c3a3fc>] ieee80211_work_work+0x1ec/0x340 [mac80211]
[ 2742.786584]  [<c0165819>] run_workqueue+0x89/0x150
[ 2742.786596]  [<f8c3a210>] ? ieee80211_work_work+0x0/0x340 [mac80211]
[ 2742.786600]  [<c0165fa7>] worker_thread+0x77/0xd0
[ 2742.786603]  [<c0169c70>] ? autoremove_wake_function+0x0/0x40
[ 2742.786607]  [<c0165f30>] ? worker_thread+0x0/0xd0
[ 2742.786610]  [<c01699d4>] kthread+0x74/0x80
[ 2742.786613]  [<c0169960>] ? kthread+0x0/0x80
[ 2742.786617]  [<c0103306>] kernel_thread_helper+0x6/0x10
[ 2742.786619] ---[ end trace cda108d0761e7f98 ]---
Comment 10 John W. Linville 2010-06-07 15:53:15 UTC
I guess 79733a865c didn't fix it afterall, although I agree that it seems like it should have done so...

Johannes, any other ideas?
Comment 11 John W. Linville 2010-08-18 19:53:57 UTC
Johannes, ping?
Comment 12 Johannes Berg 2010-08-18 20:07:56 UTC
Err, sorry, no more ideas really.
Comment 13 John W. Linville 2011-01-18 19:07:18 UTC
Does this issue persist with 2.6.37 or later kernels?
Comment 14 Cristian Aravena Romero 2011-01-18 22:03:42 UTC
Not message in kernel 2.6.37 =)

Note You need to log in before you can comment on or make changes to this bug.