Bug 15932 - Drop in throughput in rtl8187se with WPA
Summary: Drop in throughput in rtl8187se with WPA
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Staging (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_staging@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-07 12:00 UTC by Pablo Castellano
Modified: 2012-07-11 16:10 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments
Dmesg output (12.40 KB, text/plain)
2010-06-18 14:34 UTC, Pablo Castellano
Details
Dmesg log (6.92 KB, text/plain)
2010-12-22 14:39 UTC, Diogo Falcomer
Details

Description Pablo Castellano 2010-05-07 12:00:00 UTC
My laptop uses the rtl8187se driver and when I'm connected to a WPA protected network, the connection is very unstable. It suffers from drops in throughput continuously and at the moment my solution is using ndiswrapper.

Let me know if I can provide more details and help to fix this issue.
Comment 1 Greg Kroah-Hartman 2010-05-07 15:27:44 UTC
Does 2.6.34-rc6 work better?

How about 2.6.33?
Comment 2 Pablo Castellano 2010-06-09 19:15:18 UTC
Hi Greg, I have installed 2.6.34 today. I will test it in the next days.
Comment 3 Pablo Castellano 2010-06-18 14:32:56 UTC
After some days of testing, I can say that 2.6.34 is a bit better from what I remember being 2.6.32, but it's still very buggy.
It's difficult to test because drops of throughput and disconnections are ocasional.
Comment 4 Pablo Castellano 2010-06-18 14:34:00 UTC
Created attachment 26845 [details]
Dmesg output

JFTR: the module is now called r8187se.

This attachment shows the module output that floods dmesg.
Comment 5 Diogo Falcomer 2010-12-22 14:37:53 UTC
I had the same problem. My notebook is Running Ubuntu 10.4 32bits.
When I use the wireless at work, the traffic data stops, but the connection remains up. The connection is WPA/WPA 2 Personal. 

Dmesg returns the error attached.


It happens a lot when it opens and closes the door.
Comment 6 Diogo Falcomer 2010-12-22 14:39:10 UTC
Created attachment 41302 [details]
Dmesg log

Note You need to log in before you can comment on or make changes to this bug.