Bug 15893 - Alps: No edge-scrolling since 2.6.34-rc5
Alps: No edge-scrolling since 2.6.34-rc5
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-05-01 16:23 UTC by Felix Zweig
Modified: 2010-05-11 09:58 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments
dmesg of 2.6.33 (scrolling works) (88.96 KB, text/plain)
2010-05-03 21:16 UTC, Felix Zweig
Details
dmesg of 2.6.34-rc6 (no scrolling) (76.07 KB, text/plain)
2010-05-03 21:18 UTC, Felix Zweig
Details
dmesg of 2.6.34-997 (drm-intel-next, scrolling works) (84.04 KB, text/plain)
2010-05-03 21:22 UTC, Felix Zweig
Details
patch that reverts the hp pavilion support (616 bytes, patch)
2010-05-04 06:49 UTC, Dan Carpenter
Details | Diff

Description Felix Zweig 2010-05-01 16:23:54 UTC
Since 2.6.34-rc5, I'm no longer able to scroll using my touchpad on an Acer Aspire One 532h. It worked with 2.6.34-rc4, and it still works with the 2010-04-19 snapshot of 2.6.34-997 from the drm-intel-next branch (via Ubuntu's mainline repository). This happens on Ubuntu 10.04 x86_64.


$ grep -B 5 mouse /proc/bus/input/devices 
I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="PS/2 Mouse"
P: Phys=isa0060/serio1/input1
S: Sysfs=/devices/platform/i8042/serio1/input/input7
U: Uniq=
H: Handlers=mouse0 event7 
--
I: Bus=0011 Vendor=0002 Product=0008 Version=7326
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input8
U: Uniq=
H: Handlers=mouse1 event8 

$ uname -a
Linux quadratwurzel 2.6.34-020634rc6-generic #020634rc6 SMP Fri Apr 30 09:08:46 UTC 2010 x86_64 GNU/Linux
Comment 1 Dan Carpenter 2010-05-03 11:40:14 UTC
Could you try booting with the "i8042.debug" option an post your dmesg?
Comment 2 Felix Zweig 2010-05-03 21:16:25 UTC
Created attachment 26214 [details]
dmesg of 2.6.33 (scrolling works)
Comment 3 Felix Zweig 2010-05-03 21:18:33 UTC
Created attachment 26215 [details]
dmesg of 2.6.34-rc6 (no scrolling)
Comment 4 Felix Zweig 2010-05-03 21:22:43 UTC
Created attachment 26217 [details]
dmesg of 2.6.34-997 (drm-intel-next, scrolling works)
Comment 5 Dan Carpenter 2010-05-03 22:16:51 UTC
Great.  Thanks for the information, that really helps.

Here is the email I sent to linux-input.  I added you to the CC list as well.

Subject: Re: [Bug 15893] Alps: No edge-scrolling since 2.6.34-rc5 

It looks like the "Acer Aspire One 532h" and the "HP Pavilion dm3" have the same signature but they behave differently.

As a result commit 5e28d8eb68 "Input: ALPS - add signature for HP Pavilion dm3 laptops" fixes things for dm3 but breaks the Acer Aspire One 532h which was working (with a userspace driver maybe??).

Here is the relevant "i8042.debug" output from bz 15893:

drivers/input/serio/i8042.c: d4 -> i8042 (command) [535]
drivers/input/serio/i8042.c: e9 -> i8042 (parameter) [535]
drivers/input/serio/i8042.c: fa <- i8042 (interrupt, 1, 12) [535]
drivers/input/serio/i8042.c: 73 <- i8042 (interrupt, 1, 12) [536]
drivers/input/serio/i8042.c: 02 <- i8042 (interrupt, 1, 12) [536]
drivers/input/serio/i8042.c: 64 <- i8042 (interrupt, 1, 12) [536]

What's the right way to handle this?
Comment 6 Dan Carpenter 2010-05-04 06:49:14 UTC
Created attachment 26218 [details]
patch that reverts the hp pavilion support

The HP support was already reverted in the linux-input devel tree for unrelated reasons.

Felix, I've attached a patch for you until the official patch gets pushed to Linus's tree.  We'll close this bug when it get's fixed in mainline.
Comment 7 Rafael J. Wysocki 2010-05-04 21:18:12 UTC
Patch : https://bugzilla.kernel.org/attachment.cgi?id=26218
Handled-By :  Dan Carpenter <error27@gmail.com>
Comment 8 Dmitry Torokhov 2010-05-08 06:00:37 UTC
The offending patch has been reverted from mainline, closing.
Comment 9 Felix Zweig 2010-05-11 09:58:53 UTC
I can confirm that scrolling works again in 2.6.34-rc7. Thank you!

Note You need to log in before you can comment on or make changes to this bug.