Bug 15839 - [Sony Corporation VGN-NS130FE] suspend/resume failure
[Sony Corporation VGN-NS130FE] suspend/resume failure
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
https://bugs.launchpad.net/bugs/568655
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-04-22 20:48 UTC by Cristian Aravena Romero
Modified: 2013-03-16 16:54 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.34-rc7
Tree: Mainline
Regression: No


Attachments
/var/log/syslog (121.98 KB, application/octet-stream)
2010-04-24 03:44 UTC, Cristian Aravena Romero
Details
/var/log/kern.log (119.52 KB, application/octet-stream)
2010-04-25 01:10 UTC, Cristian Aravena Romero
Details
/proc/acpi (12.80 KB, application/octet-stream)
2010-04-25 01:17 UTC, Cristian Aravena Romero
Details
#dmidecode (5.07 KB, text/plain)
2010-04-25 01:29 UTC, Cristian Aravena Romero
Details
kernel trace 2.6.33.2-57.fc13.x86_64 (1.94 KB, text/plain)
2010-04-26 19:29 UTC, Henry Kroll
Details
$dmesg 2.6.34-020634rc7-generic (52.31 KB, text/plain)
2010-05-11 19:28 UTC, Cristian Aravena Romero
Details
dmesg 2.6.35-rc3 (60.76 KB, text/plain)
2010-06-14 23:09 UTC, Cristian Aravena Romero
Details
Message in console (63.65 KB, image/png)
2010-06-20 18:52 UTC, Cristian Aravena Romero
Details

Description Cristian Aravena Romero 2010-04-22 20:48:40 UTC
Open bug in Launchpad.net:
https://bugs.launchpad.net/bugs/568655
Comment 1 Cristian Aravena Romero 2010-04-24 03:18:02 UTC
[   60.004987] ------------[ cut here ]------------
[   60.005000] WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143 local_bh_enable_ip+0x61/0x90()
[   60.005003] Hardware name: VGN-NS130FE
[   60.005005] Modules linked in: aes_i586 aes_generic binfmt_misc ppdev vboxdrv joydev snd_hda_codec_realtek fbcon tileblit font bitblit softcursor vga16fb vgastate arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq ath9k i915 snd_timer snd_seq_device drm_kms_helper mac80211 ath uvcvideo videodev v4l1_compat snd sony_laptop drm sdhci_pci sdhci psmouse cfg80211 serio_raw led_class intel_agp i2c_algo_bit video agpgart soundcore snd_page_alloc output lp parport usbhid hid ohci1394 ieee1394 ahci sky2
[   60.005068] Pid: 967, comm: wpa_supplicant Not tainted 2.6.32-21-generic #32-Ubuntu
[   60.005070] Call Trace:
[   60.005078]  [<c014c3d2>] warn_slowpath_common+0x72/0xa0
[   60.005081]  [<c0153381>] ? local_bh_enable_ip+0x61/0x90
[   60.005084]  [<c0153381>] ? local_bh_enable_ip+0x61/0x90
[   60.005087]  [<c014c41a>] warn_slowpath_null+0x1a/0x20
[   60.005090]  [<c0153381>] local_bh_enable_ip+0x61/0x90
[   60.005095]  [<c058b826>] _spin_unlock_bh+0x16/0x20
[   60.005110]  [<f878d18f>] ath_tx_node_cleanup+0x14f/0x170 [ath9k]
[   60.005118]  [<f8787eee>] ath9k_sta_notify+0x4e/0xb0 [ath9k]
[   60.005130]  [<f85f6647>] __sta_info_unlink+0x127/0x1b0 [mac80211]
[   60.005138]  [<f8787ea0>] ? ath9k_sta_notify+0x0/0xb0 [ath9k]
[   60.005146]  [<f85f6703>] sta_info_unlink+0x33/0x50 [mac80211]
[   60.005155]  [<f85fdeca>] ieee80211_set_disassoc+0x17a/0x1d0 [mac80211]
[   60.005164]  [<f85fe1c7>] ieee80211_mgd_deauth+0x107/0x110 [mac80211]
[   60.005169]  [<c0142b80>] ? default_wake_function+0x0/0x20
[   60.005180]  [<f8603369>] ieee80211_deauth+0x19/0x20 [mac80211]
[   60.005194]  [<f8142cf8>] __cfg80211_mlme_deauth+0xd8/0x100 [cfg80211]
[   60.005202]  [<f8145e0d>] __cfg80211_disconnect+0x14d/0x1b0 [cfg80211]
[   60.005209]  [<c012a438>] ? default_spin_lock_flags+0x8/0x10
[   60.005217]  [<f8148f31>] cfg80211_wext_siwmlme+0x81/0xa0 [cfg80211]
[   60.005223]  [<c056f36b>] ioctl_standard_iw_point+0x18b/0x300
[   60.005231]  [<f8148eb0>] ? cfg80211_wext_siwmlme+0x0/0xa0 [cfg80211]
[   60.005236]  [<c056f585>] ioctl_standard_call+0xa5/0x100
[   60.005244]  [<f8148eb0>] ? cfg80211_wext_siwmlme+0x0/0xa0 [cfg80211]
[   60.005249]  [<c04c430d>] ? __dev_get_by_name+0x8d/0xb0
[   60.005252]  [<c056f922>] T.779+0xc2/0x150
[   60.005261]  [<f8148eb0>] ? cfg80211_wext_siwmlme+0x0/0xa0 [cfg80211]
[   60.005265]  [<c056fa10>] wext_handle_ioctl+0x60/0xc0
[   60.005269]  [<c04c5454>] dev_ioctl+0x614/0x720
[   60.005274]  [<c0207a34>] ? do_sync_read+0xc4/0x100
[   60.005278]  [<c04b24a3>] sock_ioctl+0x1d3/0x270
[   60.005283]  [<c02f4414>] ? security_file_permission+0x14/0x20
[   60.005286]  [<c04b22d0>] ? sock_ioctl+0x0/0x270
[   60.005290]  [<c0216231>] vfs_ioctl+0x21/0x90
[   60.005293]  [<c0216519>] do_vfs_ioctl+0x79/0x310
[   60.005295]  [<c0216817>] sys_ioctl+0x67/0x80
[   60.005299]  [<c01033ec>] syscall_call+0x7/0xb
[   60.005302] ---[ end trace 4f96e82097fda306 ]---
Comment 2 Cristian Aravena Romero 2010-04-24 03:44:58 UTC
Created attachment 26117 [details]
/var/log/syslog
Comment 3 Cristian Aravena Romero 2010-04-25 01:10:04 UTC
Created attachment 26127 [details]
/var/log/kern.log

I test kernel 2.6.34-rc5 and not off notebook.
Comment 4 Cristian Aravena Romero 2010-04-25 01:17:01 UTC
Created attachment 26128 [details]
/proc/acpi

$ uname -a
Linux zeus 2.6.34-020634rc5-generic #020634rc5 SMP Tue Apr 20 10:07:04 UTC 2010 i686 GNU/Linux
Comment 5 Cristian Aravena Romero 2010-04-25 01:29:38 UTC
Created attachment 26129 [details]
#dmidecode
Comment 6 Henry Kroll 2010-04-26 19:29:16 UTC
Created attachment 26151 [details]
kernel trace 2.6.33.2-57.fc13.x86_64

Confirmed: Compaq Presario CQ60 Notebook PC
Comment 7 John W. Linville 2010-04-27 15:06:54 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=585072

I suspect this stems from here:

commit a9f042cbe5284f34ccff15f3084477e11b39b17b
Author: Ming Lei <tom.leiming@gmail.com>
Date:   Sun Feb 28 00:56:24 2010 +0800

    ath9k: fix lockdep warning when unloading module
Comment 8 Henry Kroll 2010-04-28 00:45:31 UTC
Perhaps I spoke too soon. The problem, which was repeatable since installing Fedora 13 beta has disappeared yesterday after posting. Perhaps it was the reboot. Although kernel was not updated, I believe NetworkManager had been. I had not rebooted in a week. NetworkManager-gnome-0.8.0-7.git20100422.fc13.x86_64
Comment 9 John W. Linville 2010-04-28 13:48:50 UTC
The reporter of the Red Hat bugzilla referenced in comment 7 reports that reverting the patch mentioned there resolves his issue.

Ming Lei, do you have  a proposal for addressing both the _local_bh_enable_ip warning and the original lockdep warning?
Comment 10 Lei Ming 2010-04-28 14:17:11 UTC

Hi John,

      Same with 15761.   

Johannes has commented it already, please see 
         http://marc.info/?l=linux-wireless&m=127088247304187&w=2

Seems there is still some fix not merged to stable tree.


Thanks,
Comment 11 John W. Linville 2010-04-28 14:38:58 UTC

*** This bug has been marked as a duplicate of bug 15761 ***
Comment 12 Cristian Aravena Romero 2010-04-28 15:51:28 UTC
Please open bug, for my *not* work hibernate and suspend. my kernel _2.6.34-rc5_. The kernel _2.6.34-rc5_ not message of ERROR in module ath9k. Please see log
Comment 13 John W. Linville 2010-04-28 16:23:08 UTC
Alright, reopening to address suspend/resume problem -- please ignore the ath9k-related messages in the preceding comments...
Comment 14 Cristian Aravena Romero 2010-05-11 19:28:10 UTC
Created attachment 26346 [details]
$dmesg 2.6.34-020634rc7-generic
Comment 15 Cristian Aravena Romero 2010-06-14 23:09:04 UTC
Created attachment 26773 [details]
dmesg 2.6.35-rc3
Comment 16 Rafael J. Wysocki 2010-06-14 23:52:05 UTC
Please keep the original kernel version.  It's useful to know when the bug
appeared without going into the entry.
Comment 17 Cristian Aravena Romero 2010-06-20 18:52:58 UTC
Created attachment 26872 [details]
Message in console
Comment 18 Rafael J. Wysocki 2010-12-29 23:47:03 UTC
Please test 2.6.37-rc8 and report back.
Comment 19 Cristian Aravena Romero 2010-12-30 13:01:40 UTC
Now work fine, thanks
Comment 20 Cristian Aravena Romero 2013-03-16 05:46:06 UTC
Problem with kernel 3.8:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/568655/comments/6
Comment 21 Cristian Aravena Romero 2013-03-16 05:51:21 UTC
in comment 6 -> Attach file
Comment 22 John W. Linville 2013-03-16 16:54:38 UTC
You seriously reopened a bug from over two years ago?

Whatever problem you are having, please open a new bug with all the relevant information you can provide.  Hijacking a long-dead bug seems at best unproductive...

Note You need to log in before you can comment on or make changes to this bug.