Bug 15820 - [REGRESSION 2.6.34] Suspend fails in pm_test=processor on Dell laptop
[REGRESSION 2.6.34] Suspend fails in pm_test=processor on Dell laptop
Status: CLOSED DUPLICATE of bug 15786
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 15310
  Show dependency treegraph
 
Reported: 2010-04-20 19:27 UTC by Maciej Rutecki
Modified: 2010-05-04 21:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.34-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-04-20 19:27:48 UTC
Subject    : [REGRESSION 2.6.34] Suspend fails in pm_test=processor on Dell laptop
Submitter  : Ben Gamari <bgamari.foss@gmail.com>
Date       : 2010-04-18 14:53
Message-ID : 4bcb1cf2.116bdc0a.2008.6f5a@mx.google.com
References : http://marc.info/?l=linux-kernel&m=127160244004420&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-04-21 05:13:06 UTC
This looks like a memory management bug.

The memory bitmap code used by the hibernation subsystem hasn't changed for a long time, so I guess the problem is architecture-related.

I'm afraid it will be difficult to pinpoint without bisecting.
Comment 2 Rafael J. Wysocki 2010-04-21 05:46:05 UTC
Hmm.  Can you try the patch from bug #15286?
Comment 3 Rafael J. Wysocki 2010-04-21 05:46:57 UTC
Sorry, typo.  Please try the patch from bug #15786.
Comment 4 Rafael J. Wysocki 2010-05-04 21:23:09 UTC

*** This bug has been marked as a duplicate of bug 15786 ***

Note You need to log in before you can comment on or make changes to this bug.