Bug 15819 - 2.6.34rc4 NFS writeback regression (bisected): client often fails to delete things it just created
2.6.34rc4 NFS writeback regression (bisected): client often fails to delete t...
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: NFS
All Linux
: P1 normal
Assigned To: Trond Myklebust
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-20 19:22 UTC by Maciej Rutecki
Modified: 2010-05-04 21:19 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.34-rc4
Tree: Mainline
Regression: Yes


Attachments
NFS: Fix an unstable write data integrity race (3.67 KB, patch)
2010-04-22 20:56 UTC, Trond Myklebust
Details | Diff

Description Maciej Rutecki 2010-04-20 19:22:52 UTC
Subject    : 2.6.34rc4 NFS writeback regression (bisected): client often fails to delete things it just created
Submitter  : Nix <nix@esperi.org.uk>
Date       : 2010-04-17 19:43
Message-ID : 87tyr9dfvv.fsf@spindle.srvr.nix
References : http://marc.info/?l=linux-kernel&m=127153342205389&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit acdc53b2146c7ee67feb1f02f7bc3020126514b8
Author: Trond Myklebust <Trond.Myklebust@netapp.com>
Date:   Fri Feb 19 17:03:26 2010 -0800

    NFS: Replace __nfs_write_mapping with sync_inode()

    Signed-off-by: Trond Myklebust <Trond.Myklebust@netapp.com>

First-Bad-Commit : acdc53b2146c7ee67feb1f02f7bc3020126514b8
Comment 1 Trond Myklebust 2010-04-22 20:56:30 UTC
Created attachment 26100 [details]
NFS: Fix an unstable write data integrity race

The above patch has been confirmed to fix this bug, and has been
queued for mainline inclusion.
Comment 2 Rafael J. Wysocki 2010-05-04 21:19:06 UTC
Fixed by commit 71d0a6112a363e703e383ae5b12c492485c39701 .

Note You need to log in before you can comment on or make changes to this bug.