Bug 15811 - ark3116 changes minor if open across suspend
ark3116 changes minor if open across suspend
Status: RESOLVED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2010-04-19 11:45 UTC by Ferenc Wágner
Modified: 2013-04-09 06:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.4
Tree: Mainline
Regression: No


Attachments

Description Ferenc Wágner 2010-04-19 11:45:52 UTC
My USB serial dongle is driven by ark3116. After plugging it in, it's assigned to node /dev/ttyUSB0. However, if it's opened by some process when I suspend the machine, after resume it appears as /dev/ttyUSB1. It changes back and forth between ttyUSB0 and ttyUSB1 if it's opened at suspend time (and the connection is broken each time, of course). It keeps its minor if it isn't opened at suspend time. Otherwise the device works well with both minors. The issue is reproducible by

cd /sys/power
echo devices >pm_test
echo mem >state </dev/ttyUSB0
Comment 1 Zhang Rui 2012-01-18 02:03:07 UTC
It's great that kernel bugzilla is back.

can you please verify if the problem still exists in the latest upstream
kernel?
Comment 2 Ferenc Wágner 2012-01-22 23:20:13 UTC
Yes, the issue is present under 3.2. However, now I think it basically comes down to missing suspend/resume support in the ark3116 driver: the USB core has no choice besides unbinding the driver for the suspend period. If so, this is more a feature request than a bug report...
Comment 3 Zhang Rui 2012-05-24 07:31:38 UTC
re-assign to the USB experts.

Note You need to log in before you can comment on or make changes to this bug.