Bug 15773 - 2.6.34-rc3-git9 boot hang
2.6.34-rc3-git9 boot hang
Status: CLOSED DUPLICATE of bug 15749
Product: ACPI
Classification: Unclassified
Component: Other
x86-64 Linux
: P1 high
Assigned To: acpi_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-12 23:28 UTC by Helber Maciel Guerra
Modified: 2010-04-16 21:36 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.34-rc3
Tree: Mainline
Regression: Yes


Attachments
acpidump (176.18 KB, application/octet-stream)
2010-04-12 23:28 UTC, Helber Maciel Guerra
Details
Config File + lspci + lsmod (76.41 KB, application/octet-stream)
2010-04-12 23:31 UTC, Helber Maciel Guerra
Details
dmesg (121.78 KB, application/octet-stream)
2010-04-13 03:13 UTC, Helber Maciel Guerra
Details
If help this atach diff from diffs git8 --> git9 (21.05 KB, text/plain)
2010-04-13 03:17 UTC, Helber Maciel Guerra
Details
lspci -vvnn (23.07 KB, application/octet-stream)
2010-04-13 03:24 UTC, Helber Maciel Guerra
Details
dmesg kernel 2.6.34-rc4 git with acpi=off (118.91 KB, text/plain)
2010-04-14 06:22 UTC, Helber Maciel Guerra
Details

Description Helber Maciel Guerra 2010-04-12 23:28:42 UTC
Created attachment 25976 [details]
acpidump

Steps to reproduce:
kernel vanilla patch 2.6.34-rc3-git9 or 2.6.34-rc3-git10
Boot process stop on detect ata ide.
I can boot only with acpi=off.

Compared normal dmesg point a freeze point:

[    1.782072] device: 'host3': device_add
[    1.782078] bus: 'scsi': add device host3
[    1.782086] PM: Adding info for scsi:host3
[    1.782168] device: 'host3': device_add
[    1.782191] PM: Adding info for No Bus:host3
<<<<<<<<<< ---------  Boot Stop at this point   
[    1.782474] ata1: SATA max UDMA/133 abar m1024@0xfebffc00 port 0xfebffd00 irq 22
[    1.782620] ata2: SATA max UDMA/133 abar m1024@0xfebffc00 port 0xfebffd80 irq 22
[    1.782762] ata3: SATA max UDMA/133 abar m1024@0xfebffc00 port 0xfebffe00 irq 22
[    1.782908] ata4: SATA max UDMA/133 abar m1024@0xfebffc00 port 0xfebffe80 irq 22
[    1.783129] driver: '0000:00:12.0': driver_bound: bound to device 'ahci'
[    1.783135] bus: 'pci': really_probe: bound device 0000:00:12.0 to driver ahci
[    1.783314] bus: 'pci': add driver pata_atiixp
[    1.783330] bus: 'pci': driver_probe_device: matched device 0000:00:14.1 with driver pata_atiixp
[    1.783335] bus: 'pci': really_probe: probing driver pata_atiixp with device 0000:00:14.1
[    1.784321]   alloc irq_desc for 16 on node 0
[    1.784325]   alloc kstat_irqs on node 0
[    1.784339] pata_atiixp 0000:00:14.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    1.784555] pata_atiixp 0000:00:14.1: setting latency timer to 64



Some info:
#> uname -a
Linux notehelber.dyndns.org 2.6.34-rc3-git8-helber.x86_64 #32 SMP PREEMPT Thu Apr 8 13:06:28 BRT 2010 x86_64 x86_64 x86_64 GNU/Linux

Distribution: Fedora 12

Compiler: gcc gcc version 4.4.3 20100127 (Red Hat 4.4.3-4) (GCC)
Comment 1 Helber Maciel Guerra 2010-04-12 23:31:48 UTC
Created attachment 25977 [details]
Config File + lspci + lsmod

#> lspci 
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
06:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
07:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
07:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
07:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
07:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)
07:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


#> lsmod 
Module                  Size  Used by
nls_iso8859_1           4561  1 
nls_cp437               6263  1 
vfat                    8435  1 
fat                    45197  1 vfat
vboxnetadp              4387  0 
vboxnetflt             10199  0 
vboxdrv              1745098  2 vboxnetadp,vboxnetflt
vmnet                  39711  13 
vmblock                11174  1 
vsock                  37944  0 
vmci                   50143  1 vsock
vmmon                  68282  0 
tun                    13129  2 
powernow_k8            14553  1 
xfs                   826786  1 
exportfs                3381  1 xfs
dm_mirror              11730  0 
dm_region_hash          9949  1 dm_mirror
dm_log                  8728  2 dm_mirror,dm_region_hash
kvm                   269916  0 
sdhci_pci               6713  0 
ath9k                  63623  0 
sdhci                  15662  1 sdhci_pci
ath9k_common            2695  1 ath9k
processor              27915  1 powernow_k8
ath9k_hw              218494  2 ath9k,ath9k_common
mmc_core               58339  1 sdhci
thermal                13228  0 
k8temp                  3619  0 
i2c_piix4               8951  0 
pcmcia                 34740  0 
dm_multipath           14620  0 
firewire_ohci          20637  0 
yenta_socket           20607  0 
rsrc_nonstatic          7874  1 yenta_socket
firewire_core          44794  1 firewire_ohci
pcmcia_core            16039  3 pcmcia,yenta_socket,rsrc_nonstatic
sd_mod                 28864  6 
dm_mod                 59605  3 dm_mirror,dm_log,dm_multipath
Comment 2 Zhang Rui 2010-04-13 02:03:47 UTC
please attach the dmesg output in both cases.
Comment 3 Len Brown 2010-04-13 02:07:12 UTC
So boot hangs at 2.6.34-rc3-git9 and worked properly
in 2.6.34-rc3-git8?
If no, what was the latest release that worked?

Is it possible to git-bisect to find which patch caused the regression?

It may be that we broke this with the latest ACPI merge.
See if this commit is broken or working
commit c25f7cf2032aaac9bd50d6eee982719878538082
Merge: f79e1ce dadf28a ac7729d 3162b6f bc73675 b7b30de bf02bd2 1638bca 0f9b75e 17c452f
Author: Len Brown <len.brown@intel.com>
Date:   Tue Apr 6 17:06:22 2010 -0400

    Merge branches 'battery', 'bugzilla-14667', 'bugzilla-15096', 'bugzilla-15480', 'bugzilla-1552

And if it is broken, then likely one of the fixes in it caused the regression.
Comment 4 Helber Maciel Guerra 2010-04-13 03:12:29 UTC
In 2.6.34-rc3-git8 and after all works.

Was tested on:
2.6.34-rc3-git9
2.6.34-rc3-git10
2.6.34-rc4

Boot is broke without any response (just pressing power a few seconds).
Comment 5 Helber Maciel Guerra 2010-04-13 03:13:48 UTC
Created attachment 25978 [details]
dmesg
Comment 6 Helber Maciel Guerra 2010-04-13 03:17:10 UTC
Created attachment 25979 [details]
If help this atach diff from diffs git8 --> git9

Some of this changes do my system stop to work.
Comment 7 Helber Maciel Guerra 2010-04-13 03:24:01 UTC
Created attachment 25980 [details]
lspci -vvnn
Comment 8 Helber Maciel Guerra 2010-04-13 14:26:26 UTC
(In reply to comment #3)
> So boot hangs at 2.6.34-rc3-git9 and worked properly
> in 2.6.34-rc3-git8?
> If no, what was the latest release that worked?
> 
> Is it possible to git-bisect to find which patch caused the regression?
> 
> It may be that we broke this with the latest ACPI merge.
> See if this commit is broken or working
> commit c25f7cf2032aaac9bd50d6eee982719878538082
> Merge: f79e1ce dadf28a ac7729d 3162b6f bc73675 b7b30de bf02bd2 1638bca 0f9b75e
> 17c452f
> Author: Len Brown <len.brown@intel.com>
> Date:   Tue Apr 6 17:06:22 2010 -0400
> 
>     Merge branches 'battery', 'bugzilla-14667', 'bugzilla-15096',
> 'bugzilla-15480', 'bugzilla-1552
> 
> And if it is broken, then likely one of the fixes in it caused the regression.

Confirmed:
Latest patch that work:
2.6.34-rc3-git8
Latest commit that worked:
WORK:
commit ac7729da880e742613129ee6dea0045328670d2d

Not Work:
commit c25f7cf2032aaac9bd50d6eee982719878538082
2.6.34-rc3-git9 
2.6.34-rc3-git10
2.6.34-rc4
Comment 9 Helber Maciel Guerra 2010-04-14 06:22:22 UTC
Created attachment 25998 [details]
dmesg kernel 2.6.34-rc4 git with acpi=off

dmesg kernel 2.6.34-rc4 git
latest commit 2ba3abd8186f24c7fb418927025b4e2120e3a362
Date:   Tue Apr 13 17:49:48 2010 -0700

Can i enable some debug to take some trace?
Comment 10 Len Brown 2010-04-15 02:16:40 UTC
> WORK:
> commit ac7729da880e742613129ee6dea0045328670d2d

> Not Work:
> commit c25f7cf2032aaac9bd50d6eee982719878538082

okay, as there are 12 commits between these two, what you want
to do is this:

git bisect start
git bisect good ac7729da880e742613129ee6dea0045328670d2d
git bisect bad c25f7cf2032aaac9bd50d6eee982719878538082
then build each kernel, boot it, and respond
with "git bisect good" or "git bisect bad" depending
on the results.

Or, you can take a lucky guess and if
git revert dadf28a10c3eb29421837a2e413ab869ebd9e168
makes the issue go away, then please test the patch
in bug 15749
Comment 11 Helber Maciel Guerra 2010-04-15 15:39:41 UTC
OK.
Works whith patch https://bugzilla.kernel.org/attachment.cgi?id=25962
Is same problem reported in:
https://bugzilla.kernel.org/show_bug.cgi?id=15749

I try with sugested patch with git:
commit 250541fca717a5c9b0d3710e737b2ca32ebb6fbc

2.6.34-rc4-helber.git-test-00082-g250541f-dirty
Comment 12 Helber Maciel Guerra 2010-04-15 15:40:53 UTC

*** This bug has been marked as a duplicate of bug 15749 ***

Note You need to log in before you can comment on or make changes to this bug.