Bug 15767 - Kernel does not recognize USB devices on some machines
Kernel does not recognize USB devices on some machines
Status: CLOSED DUPLICATE of bug 15749
Product: Other
Classification: Unclassified
Component: Modules
All Linux
: P1 normal
Assigned To: other_modules
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-04-12 10:44 UTC by Susan Cragin
Modified: 2010-10-28 18:16 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32-20
Tree: Mainline
Regression: Yes


Attachments

Description Susan Cragin 2010-04-12 10:44:10 UTC
Kernels from 2.6.32-20 up to Friday's git do not recognize certain USB devices, and hence do not load. 
The problem was brought to attention in the Ubuntu bug tracker system, bug 561140.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561140
However, I compiled and installed the kernel from git on Friday, 2.6.34, and the problem is with the kernel.
Comment 1 Andrew Morton 2010-04-12 23:31:48 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Mon, 12 Apr 2010 10:45:33 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> https://bugzilla.kernel.org/show_bug.cgi?id=15767
> 
>            Summary: Kernel does not recognize USB devices on some machines
>            Product: Other
>            Version: 2.5
>     Kernel Version: 2.6.32-20
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Modules
>         AssignedTo: other_modules@kernel-bugs.osdl.org
>         ReportedBy: susancragin@earthlink.net
>         Regression: Yes
> 
> 
> Kernels from 2.6.32-20 up to Friday's git do not recognize certain USB devices,
> and hence do not load. 
> The problem was brought to attention in the Ubuntu bug tracker system, bug
> 561140.
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561140
> However, I compiled and installed the kernel from git on Friday, 2.6.34, and
> the problem is with the kernel.

Said to be a post-2.6.32 regression.
Comment 2 Alan Stern 2010-04-13 03:16:13 UTC
On Mon, 12 Apr 2010, Andrew Morton wrote:

> > https://bugzilla.kernel.org/show_bug.cgi?id=15767
> > 
> >            Summary: Kernel does not recognize USB devices on some machines
> >            Product: Other
> >            Version: 2.5
> >     Kernel Version: 2.6.32-20

> > Kernels from 2.6.32-20 up to Friday's git do not recognize certain USB devices,
> > and hence do not load. 

What makes you think that the kernel doesn't recognize certain USB 
devices?  Which devices doesn't it recognize?  Does unplugging those 
devices make any difference?

Failure to recognize a USB device will not cause the kernel to fail to 
load.  Most likely the problem has a different cause.  You can test 
this by booting with "nousb" on the kernel command line; that will 
prevent the USB stack from running at all.

> > The problem was brought to attention in the Ubuntu bug tracker system, bug
> > 561140.
> > https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561140
> > However, I compiled and installed the kernel from git on Friday, 2.6.34, and
> > the problem is with the kernel.

Does that kernel contain the fix listed in the Ubuntu bug report?  Have 
you tried booting with "acpi=off" on the command line, as recommended 
in the bug report?

You need to provide much more information; otherwise nobody will have a
clue as to where to look for the problem.  For example, apart from all
the questions above, what shows up on the screen when the computer
hangs?

Alan Stern
Comment 3 Alan Stern 2010-05-24 21:33:40 UTC
On Mon, 12 Apr 2010, Andrew Morton wrote:

> > https://bugzilla.kernel.org/show_bug.cgi?id=15767
> > 
> >            Summary: Kernel does not recognize USB devices on some machines

> > Kernels from 2.6.32-20 up to Friday's git do not recognize certain USB devices,
> > and hence do not load. 
> > The problem was brought to attention in the Ubuntu bug tracker system, bug
> > 561140.
> > https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561140
> > However, I compiled and installed the kernel from git on Friday, 2.6.34, and
> > the problem is with the kernel.
> 
> Said to be a post-2.6.32 regression.

Andrew:

The ubuntu bug report now says that the issue has been resolved and
it's really another duplicate of Bugzilla #15749.  Do you want to mark 
this entry as a duplicate and close it out?

Alan Stern
Comment 4 Andrew Morton 2010-05-24 21:42:06 UTC

*** This bug has been marked as a duplicate of bug 15749 ***
Comment 5 Andrew Morton 2010-05-24 21:43:38 UTC
On Mon, 24 May 2010 17:33:01 -0400 (EDT)
Alan Stern <stern@rowland.harvard.edu> wrote:

> On Mon, 12 Apr 2010, Andrew Morton wrote:
> 
> > > https://bugzilla.kernel.org/show_bug.cgi?id=15767
> > > 
> > >            Summary: Kernel does not recognize USB devices on some machines
> 
> > > Kernels from 2.6.32-20 up to Friday's git do not recognize certain USB devices,
> > > and hence do not load. 
> > > The problem was brought to attention in the Ubuntu bug tracker system, bug
> > > 561140.
> > > https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561140
> > > However, I compiled and installed the kernel from git on Friday, 2.6.34, and
> > > the problem is with the kernel.
> > 
> > Said to be a post-2.6.32 regression.
> 
> Andrew:
> 
> The ubuntu bug report now says that the issue has been resolved and
> it's really another duplicate of Bugzilla #15749.  Do you want to mark 
> this entry as a duplicate and close it out?
> 

Done, thanks.

Note You need to log in before you can comment on or make changes to this bug.