Bug 15763 - ath9k: ath_tx_node_cleanup: WARNING: at kernel/softirq.c:143 _local_bh_enable_ip
Summary: ath9k: ath_tx_node_cleanup: WARNING: at kernel/softirq.c:143 _local_bh_enable_ip
Status: RESOLVED DUPLICATE of bug 15761
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-11 14:50 UTC by Sascha Wessel
Modified: 2010-04-12 13:12 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33.2
Tree: Mainline
Regression: No


Attachments

Description Sascha Wessel 2010-04-11 14:50:32 UTC
I get the following warning (AP Mode - hostapd):
[  137.608436] ------------[ cut here ]------------
[  137.608482] WARNING: at kernel/softirq.c:143 _local_bh_enable_ip+0x33/0x6b()
[  137.608499] Modules linked in: pppoe pppox tun ppp_generic ipt_MASQUERADE iptable_nat nf_nat xt_TCPMSS ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 iptable_filter ip_tables xt_tcpudp nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables pc87360 hwmon_vid geodewdt arc4 ohci_hcd ath9k ath9k_common ecb mac80211 hisax ath9k_hw ath aes_i586 crc_ccitt ehci_hcd cfg80211 aes_generic usbcore isdn rfkill cs5535_mfgpt geode_aes geode_rng via_rhine nls_base led_class serio_raw mii rng_core cs5535_gpio slhc ext3 jbd mbcache ide_gd_mod ata_generic pata_amd libata scsi_mod cs5536 ide_core
[  137.608512] Pid: 1680, comm: ifconfig Not tainted 2.6.33.2 #1
[  137.608512] Call Trace:
[  137.608512]  [<c102f3f4>] ? warn_slowpath_common+0x5d/0x70
[  137.608512]  [<e0ddbebf>] ? ath9k_sta_notify+0x0/0x77 [ath9k]
[  137.608512]  [<c102f412>] ? warn_slowpath_null+0xb/0xd
[  137.608512]  [<c103449b>] ? _local_bh_enable_ip+0x33/0x6b
[  137.608512]  [<e0ddf8f7>] ? ath_tx_node_cleanup+0x110/0x128 [ath9k]
[  137.608512]  [<e0ddbebf>] ? ath9k_sta_notify+0x0/0x77 [ath9k]
[  137.608512]  [<e0d8540c>] ? __sta_info_unlink+0x11c/0x169 [mac80211]
[  137.608512]  [<e0d859ad>] ? sta_info_flush+0x5e/0xc6 [mac80211]
[  137.608512]  [<e0d8d3af>] ? ieee80211_stop+0x69/0x411 [mac80211]
[  137.608512]  [<c12537af>] ? _raw_spin_lock_bh+0x8/0x1e
[  137.608512]  [<c11d32f4>] ? dev_deactivate+0x7f/0xa2
[  137.608512]  [<c11c53dd>] ? dev_close+0x60/0x7d
[  137.608512]  [<c11c4ec3>] ? dev_change_flags+0x8f/0x13a
[  137.608512]  [<c1201dbf>] ? devinet_ioctl+0x247/0x4dd
[  137.608512]  [<c11b775d>] ? sock_ioctl+0x1bb/0x1dd
[  137.608512]  [<c11b75a2>] ? sock_ioctl+0x0/0x1dd
[  137.608512]  [<c10ba83f>] ? vfs_ioctl+0x1c/0x7d
[  137.608512]  [<c10baddb>] ? do_vfs_ioctl+0x496/0x4da
[  137.608512]  [<c109a465>] ? handle_mm_fault+0x3a0/0x885
[  137.608512]  [<c10bae63>] ? sys_ioctl+0x44/0x64
[  137.608512]  [<c125398c>] ? syscall_call+0x7/0xb
[  137.608512] ---[ end trace 5841540b0634561b ]---

Similar warnings:
* http://www.kerneloops.org/searchweek.php?search=ath_tx_node_cleanup

Hardware:
* Soekris net5501-70
* Sparklan WMIA-199N
00:11.0 Network controller: Atheros Communications Inc. AR9160 802.11abgn Wireless PCI Adapter (rev 01)
        Subsystem: Atheros Communications Inc. Device 2082
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 168, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 15
        Region 0: Memory at a0010000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=100mA PME(D0+,D1-,D2-,D3hot+,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: ath9k

Please let me know whether more information is needed or what kind of debugging is recommended.
Comment 1 John W. Linville 2010-04-12 13:12:34 UTC

*** This bug has been marked as a duplicate of bug 15761 ***

Note You need to log in before you can comment on or make changes to this bug.