Bug 15759 - my KDE-4.4.2 BAttery Monitor APplet dislike the ACPI changes in 2.6.34-rc3 betweeen f5284e7..cf90bfe
my KDE-4.4.2 BAttery Monitor APplet dislike the ACPI changes in 2.6.34-rc3 b...
Status: CLOSED DUPLICATE of bug 15749
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: acpi_power-battery
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-11 13:14 UTC by Maciej Rutecki
Modified: 2010-04-14 20:44 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.34-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-04-11 13:14:47 UTC
Subject    : my KDE-4.4.2 BAttery Monitor APplet dislike the ACPI changes in 2.6.34-rc3  betweeen f5284e7..cf90bfe
Submitter  : Toralf Förster <toralf.foerster@gmx.de>
Date       : 2010-04-08 16:12
Message-ID : 201004081812.10656.toralf.foerster@gmx.de
References : http://marc.info/?l=linux-kernel&m=127074316624855&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Toralf Förster 2010-04-11 14:45:27 UTC
FWIW here's my reply to the initial mail with some dmesg info : http://marc.info/?l=linux-kernel&m=127074346725322&w=2
Comment 2 Alexey Starikovskiy 2010-04-11 20:04:07 UTC

*** This bug has been marked as a duplicate of bug 15749 ***
Comment 3 Toralf Förster 2010-04-13 18:16:14 UTC
I bisected the ACPI error message down to this :

tfoerste@n22 ~/devel/linux-2.6 $ make
scripts/kconfig/conf -s arch/x86/Kconfig
-..
  CC      ipc/syscall.o
ipc/syscall.c:17: error: conflicting types for ‘sys_ipc’
include/linux/syscalls.h:691: error: previous declaration of ‘sys_ipc’ was here
make[1]: *** [ipc/syscall.o] Error 1
make: *** [ipc] Error 2
(reverse-i-search)`skip': cat ~/^Cipped 
tfoerste@n22 ~/devel/linux-2.6 $ git bisect skip
There are only 'skip'ped commits left to test.
The first bad commit could be any of:
1ee4d61fd9822fb89e63b88a66848477087cd82e
bc73675b99fd9850dd914be01d71af99c5d2a1ae
We cannot bisect more!
Comment 4 Alexey Starikovskiy 2010-04-13 18:45:23 UTC
Toralf,

Just use the patch from #15749.
Comment 5 Toralf Förster 2010-04-13 19:24:43 UTC
(In reply to comment #4)
> Toralf,
> 
> Just use the patch from #15749.

Yep - that solved it.

Unfortunately I wasn't on Cc: at this bug report (or I ignored the appropriate mail) - b/c otherwise I wouldn't bisect a already discovered issue ... :-/

Note You need to log in before you can comment on or make changes to this bug.