Bug 15756 - HPET module broken with Dell Precision M6500
Summary: HPET module broken with Dell Precision M6500
Status: CLOSED DUPLICATE of bug 15663
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_bios
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-11 09:36 UTC by Daniele Rondina
Modified: 2010-09-29 01:57 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32/2.6.33
Tree: Mainline
Regression: No


Attachments

Description Daniele Rondina 2010-04-11 09:36:12 UTC
Hi, i have a DELL Precision M6500 and it seems that HPET module is broken. Same problem with previous version 2.6.32.

I don't know if it is correct insert this bug on this section, sorry in advance for wrong section.

I'm currently use vanilla sources with gentoo patches.

Bye
Ge@@ru

[    5.074222] ------------[ cut here ]------------
[    5.074227] WARNING: at arch/x86/kernel/hpet.c:404 hpet_next_event+0x62/0x87()
[    5.074230] Hardware name: Precision M6500                 
[    5.074232] hpet: compare register read back failed.
[    5.074234] Modules linked in:
[    5.074237] Pid: 0, comm: swapper Not tainted 2.6.33-gentoo #3
[    5.074239] Call Trace:
[    5.074243]  [<ffffffff8101e965>] ? hpet_next_event+0x62/0x87
[    5.074248]  [<ffffffff8103de32>] warn_slowpath_common+0x77/0xa4
[    5.074253]  [<ffffffff8103ded4>] warn_slowpath_fmt+0x64/0x66
[    5.074257]  [<ffffffff8156d648>] ? _raw_spin_lock_irqsave+0x18/0x34
[    5.074261]  [<ffffffff8156d394>] ? _raw_spin_unlock+0x2a/0x35
[    5.074266]  [<ffffffff81232811>] ? cpumask_next_and+0x2b/0x3c
[    5.074270]  [<ffffffff810323a2>] ? find_busiest_group+0x392/0x7ea
[    5.074274]  [<ffffffff8101e965>] hpet_next_event+0x62/0x87
[    5.074277]  [<ffffffff8101e9a3>] hpet_legacy_next_event+0xb/0xd
[    5.074281]  [<ffffffff810634ca>] clockevents_program_event+0x73/0x7c
[    5.074285]  [<ffffffff810644e5>] tick_dev_program_event+0x37/0xa5
[    5.074289]  [<ffffffff81063fa8>] tick_broadcast_oneshot_control+0x9b/0xf5
[    5.074292]  [<ffffffff8106390e>] tick_notify+0x1fd/0x35e
[    5.074298]  [<ffffffff812a680a>] ? acpi_hw_read+0x51/0x59
[    5.074302]  [<ffffffff815704fe>] notifier_call_chain+0x33/0x5b
[    5.074306]  [<ffffffff8105c598>] raw_notifier_call_chain+0xf/0x11
[    5.074309]  [<ffffffff8106331a>] clockevents_notify+0x32/0x12f
[    5.074314]  [<ffffffff812b9600>] lapic_timer_state_broadcast+0x41/0x43
[    5.074318]  [<ffffffff812b9b28>] acpi_idle_enter_bm+0x16c/0x297
[    5.074321]  [<ffffffff8102ce7f>] ? nr_iowait_cpu+0x15/0x2c
[    5.074326]  [<ffffffff8141b39b>] cpuidle_idle_call+0x9b/0x10c
[    5.074330]  [<ffffffff81001eb9>] cpu_idle+0x53/0xaa
[    5.074335]  [<ffffffff81567919>] start_secondary+0x180/0x185
[    5.074341] ---[ end trace 725b09ff5610eb29 ]---
[    5.078012] ALSA device list:
Comment 1 Zhang Rui 2010-04-13 08:41:08 UTC
please re-open it if it's not a duplicate of bug 15663.

*** This bug has been marked as a duplicate of bug 15663 ***

Note You need to log in before you can comment on or make changes to this bug.