Bug 15752 - lid or keyboard no longer trigger suspend
lid or keyboard no longer trigger suspend
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: acpi_power-sleep-wake
:
Depends on:
Blocks: 7216 15310
  Show dependency treegraph
 
Reported: 2010-04-10 20:54 UTC by Michael S. Tsirkin
Modified: 2010-04-14 12:00 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34-rc1
Tree: Mainline
Regression: Yes


Attachments
.config for 2.6.34-rc3 (76.18 KB, text/plain)
2010-04-10 20:54 UTC, Michael S. Tsirkin
Details

Description Michael S. Tsirkin 2010-04-10 20:54:47 UTC
Created attachment 25942 [details]
.config for 2.6.34-rc3

With 2.6.33, closing lid or pressing suspend button
causes sound feedback and suspend on my thinkpad t500.
This is no longer the case starting with 2.6.34-rc1:
I do not get either sound or suspend.
Verified with 2.6.34-rc1, -rc2 and -rc3.
suspend works fine from /sys/power/state
or by activating it from gnome applet

.config attached.
Comment 1 Rafael J. Wysocki 2010-04-12 21:46:12 UTC
I guess the output of acpidump might be helpful.
Comment 2 Matthew Garrett 2010-04-12 21:51:20 UTC
Also, can you run

grep -r . /sys/firmware/acpi/interrupts/

on the working and broken kernels, and attach the output?
Comment 3 Len Brown 2010-04-13 01:47:02 UTC
Please kill acpid
$ grep acpi /proc/interrupts
# cat /proc/acpi/event

open & close the lid a few times
is anything output by cat?

^C
$ grep acpi /proc/interrupts

and let us know what you see
Comment 4 Michael S. Tsirkin 2010-04-14 12:00:03 UTC
Hmm, the issue is there in -rc3 but I switched to -rc4 and it's gone.
I guess we can close it for now.

Note You need to log in before you can comment on or make changes to this bug.