Bug 15749 - bisected 2.6.34-rc3+git EC regression - can't boot after fix from bug #14667
bisected 2.6.34-rc3+git EC regression - can't boot after fix from bug #14667
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 high
Assigned To: Alexey Starikovskiy
:
: 15759 15767 15773 (view as bug list)
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-10 12:06 UTC by Ricardo Salveti de Araujo
Modified: 2010-05-24 21:42 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.34-rc3+git
Tree: Mainline
Regression: Yes


Attachments
Kernel Call Trace (631.30 KB, image/jpeg)
2010-04-10 12:11 UTC, Ricardo Salveti de Araujo
Details
Working dmesg, after reverting the patch. (80.94 KB, text/plain)
2010-04-10 12:14 UTC, Ricardo Salveti de Araujo
Details
acpidump (125.83 KB, text/plain)
2010-04-10 12:15 UTC, Ricardo Salveti de Araujo
Details
Read all bits (1.03 KB, patch)
2010-04-10 21:13 UTC, Alexey Starikovskiy
Details | Diff
Limit burst to 64 bit (1.54 KB, patch)
2010-04-11 20:00 UTC, Alexey Starikovskiy
Details | Diff

Description Ricardo Salveti de Araujo 2010-04-10 12:06:20 UTC
Hi,

Today I decided to try the latest revision from Linus' tree (0eddb519b9127c73d53db4bf3ec1d45b13f844d1), to test the latest nouveau patches, but I got stuck while booting the kernel.

You can check the acpi call trace at the attached photo.

After doing bisect I ended up at patch dadf28a10c3eb29421837a2e413ab869ebd9e168, created to fix the bug #14667.

My machine is a MacBook Pro 5,1.

After reverting this patch I was able to boot and test the latest kernel available from Linus' tree.

Please let me know if you need further information to be able to debug this bug.

Best Regards,
Ricardo Salveti
Comment 1 Ricardo Salveti de Araujo 2010-04-10 12:11:12 UTC
Created attachment 25937 [details]
Kernel Call Trace
Comment 2 Ricardo Salveti de Araujo 2010-04-10 12:14:57 UTC
Created attachment 25938 [details]
Working dmesg, after reverting the patch.
Comment 3 Ricardo Salveti de Araujo 2010-04-10 12:15:40 UTC
Created attachment 25939 [details]
acpidump
Comment 4 Rafael J. Wysocki 2010-04-10 19:22:05 UTC
First-Bad-Commit : dadf28a10c3eb29421837a2e413ab869ebd9e168

Please go back to the original kernel (ie. with the commit applied) and revert
only the changes in that commit affecting drivers/acpi/ec.c .  Please report
back whether or not that helps.
Comment 5 Alexey Starikovskiy 2010-04-10 21:13:41 UTC
Created attachment 25944 [details]
Read all bits

Please check if this patch helps.
Comment 6 Ricardo Salveti de Araujo 2010-04-10 23:24:33 UTC
Just tried the patch from comment #5 and still didn't work.

However, I was able to boot fine after removing just the changes from dadf28a10c3eb29421837a2e413ab869ebd9e168 to file drivers/acpi/acpica/exprep.c.
Comment 7 Alexey Starikovskiy 2010-04-11 20:00:58 UTC
Created attachment 25962 [details]
Limit burst to 64 bit

Please check if this patch works.
Comment 8 Alexey Starikovskiy 2010-04-11 20:04:07 UTC
*** Bug 15759 has been marked as a duplicate of this bug. ***
Comment 9 Ricardo Salveti de Araujo 2010-04-11 22:15:48 UTC
(In reply to comment #7)
> Created an attachment (id=25962) [details]
> Limit burst to 64 bit
> 
> Please check if this patch works.

This patch fix the problem.

Just tested and was able to boot without any problem.

Thanks for the fix.
Comment 10 Helber Maciel Guerra 2010-04-15 15:40:53 UTC
*** Bug 15773 has been marked as a duplicate of this bug. ***
Comment 11 Mikael Pettersson 2010-04-15 20:39:39 UTC
My FSC Amilo fails to boot 2.6.34-rc4 with a repeatable oops that looks pretty much identical to the one shown here.  Alexey's "Limit burst to 64 bit" patch solves the problem on that machine.
Comment 12 Len Brown 2010-04-16 19:37:55 UTC
patch in comment #7 is applied to acpi tree
Comment 13 Len Brown 2010-04-18 02:11:47 UTC
commit 2060c44576c79086ff24718878d7edaa7384a985
Author: Alexey Starikovskiy <astarikovskiy@suse.de>
Date:   Fri Apr 16 15:36:40 2010 -0400

    ACPI: EC: Limit burst to 64 bits

shipped in linux-2.6.34-rc4-git5
closed.
Comment 14 Andrew Morton 2010-05-24 21:42:06 UTC
*** Bug 15767 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.