Bug 15728 - 2.6.34-rc3 doesn't suspend to disk (-rc2 did)
2.6.34-rc3 doesn't suspend to disk (-rc2 did)
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 15310
  Show dependency treegraph
 
Reported: 2010-04-08 18:42 UTC by Maciej Rutecki
Modified: 2010-04-20 03:36 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34-rc3
Tree: Mainline
Regression: Yes


Attachments
patch for the issue (1.14 KB, patch)
2010-04-08 21:42 UTC, Jiri Slaby
Details | Diff

Description Maciej Rutecki 2010-04-08 18:42:41 UTC
Subject    : 2.6.34-rc3 doesn't suspend to disk (-rc2 did)
Submitter  : Jiri Kosina <jkosina@suse.cz>
Date       : 2010-04-02 0:19
Message-ID : alpine.LNX.2.00.1004020215100.8345@pobox.suse.cz
References : http://marc.info/?l=linux-kernel&m=127016758131762&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jiri Slaby 2010-04-08 20:48:06 UTC
I hit that with opensuse factory today. echo disk > /sys/power/state works fine there. The kernel is -rc2-git3 (plus other patches of course). I'll look into that later if noone beats me to it.
Comment 2 Jiri Slaby 2010-04-08 21:42:43 UTC
Created attachment 25923 [details]
patch for the issue

I'm not sure whether the second paragraph in the changelog holds. For me it works.
Comment 3 Rafael J. Wysocki 2010-04-08 22:01:20 UTC
OK, I assume you have tested it both with and without CONFIG_DEBUG_BLOCK_EXT_DEVT.

I guess it should be pushed to Linus soon.

I wonder which change broke it, though.

Handled-By : Jiri Slaby <jslaby@suse.cz>
Patch : https://bugzilla.kernel.org/attachment.cgi?id=25923
Comment 4 Jiri Slaby 2010-04-09 07:36:09 UTC
(In reply to comment #3)
> OK, I assume you have tested it both with and without
> CONFIG_DEBUG_BLOCK_EXT_DEVT.

Yes.

> I wonder which change broke it, though.

I will bisect it later and make a note here.
Comment 5 Jiri Slaby 2010-04-10 08:40:04 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > I wonder which change broke it, though.
> 
> I will bisect it later and make a note here.

I'm confused. I can reproduce it in 2.6.33 with DEBUG_BLOCK_EXT_DEVT set too. But suse with 33 and that option set worked OK. Waiting for Jiri's input.

Note You need to log in before you can comment on or make changes to this bug.