Bug 15719 - virtio_net causing kernel BUG when running under VirtualBox
virtio_net causing kernel BUG when running under VirtualBox
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-07 21:21 UTC by Rafael J. Wysocki
Modified: 2010-05-04 20:55 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.34-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-04-07 21:21:13 UTC
Subject    : Regression in virtio_net causing kernel BUG when running under VirtualBox (bisected)
Submitter  : Thomas Müller <thomas@mathtm.de>
Date       : 2010-03-27 14:32
Message-ID : 4BAE1707.2050803@mathtm.de
References : http://marc.info/?l=linux-kernel&m=126970039227740&w=4
Handled-By : Shirley Ma <mashirle@us.ibm.com>

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 9ab86bbcf8be755256f0a5e994e0b38af6b4d399
Author: Shirley Ma <mashirle@us.ibm.com>
Date:   Fri Jan 29 03:20:04 2010 +0000

    virtio_net: Defer skb allocation in receive path

    Signed-off-by: Shirley Ma <xma@us.ibm.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>
    Signed-off-by: David S. Miller <davem@davemloft.net>

First-Bad-Commit : 9ab86bbcf8be755256f0a5e994e0b38af6b4d399
Comment 1 Rafael J. Wysocki 2010-04-23 16:29:10 UTC
On Friday 23 April 2010, Thomas Müller wrote:
> Fixed by commit 0e413f22e4c1cbfe12907e462a7d739a2e316f2b.
> 
> Regards
> Thomas
> 
> On 20.04.2010 05:19, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.33.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15719
> > Subject		: virtio_net causing kernel BUG when running under VirtualBox
> > Submitter	: Thomas Müller <thomas@mathtm.de>
> > Date		: 2010-03-27 14:32 (24 days old)
> > First-Bad-Commit: http://kernel.org/git/linus/9ab86bbcf8be755256f0a5e994e0b38af6b4d399
> > Message-ID	: <4BAE1707.2050803@mathtm.de>
> > References	: http://marc.info/?l=linux-kernel&m=126970039227740&w=4
> > Handled-By	: Shirley Ma <mashirle@us.ibm.com>

Note You need to log in before you can comment on or make changes to this bug.