Bug 15718 - File corruption regression on NFS related to commit 1f36f774
File corruption regression on NFS related to commit 1f36f774
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: VFS
All Linux
: P1 normal
Assigned To: fs_vfs
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-07 21:14 UTC by Rafael J. Wysocki
Modified: 2010-04-08 20:06 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.34-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-04-07 21:14:59 UTC
Subject    : [GIT BISECT] first bad commit: 1f36f774 Switch !O_CREAT case to use of do_last()
Submitter  : Boaz Harrosh <bharrosh@panasas.com>
Date       : 2010-03-24 15:49
Message-ID : 4BAA3493.1030802@panasas.com
References : http://marc.info/?l=linux-kernel&m=126944579810350&w=4
Handled-By : Al Viro <viro@zeniv.linux.org.uk>

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.

Reportedly caused by:

commit 1f36f774b22a0ceb7dd33eca626746c81a97b6a5
Author: Al Viro <viro@zeniv.linux.org.uk>
Date:   Sat Dec 26 10:56:19 2009 -0500

    Switch !O_CREAT case to use of do_last()

    ... and now we have all intents crap well localized

    Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>

First-Bad-Commit : 1f36f774b22a0ceb7dd33eca626746c81a97b6a5
Comment 1 Rafael J. Wysocki 2010-04-08 20:06:00 UTC
On Thursday 08 April 2010, Boaz Harrosh wrote:
> On 04/08/2010 12:13 AM, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.33.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15718
> > Subject		: File corruption regression on NFS related to commit 1f36f774
> > Submitter	: Boaz Harrosh <bharrosh@panasas.com>
> > Date		: 2010-03-24 15:49 (15 days old)
> > First-Bad-Commit: http://git.kernel.org/git/linus/1f36f774b22a0ceb7dd33eca626746c81a97b6a5
> > Message-ID	: <4BAA3493.1030802@panasas.com>
> > References	: http://marc.info/?l=linux-kernel&m=126944579810350&w=4
> > Handled-By	: Al Viro <viro@zeniv.linux.org.uk>
> > 
> > 
> 
> Fix already in main line: 3e297b613491f0d4928aa652a2cd266aa06dc409
> 	Author: Al Viro <viro@zeniv.linux.org.uk>
> 	Restore LOOKUP_DIRECTORY hint handling in final lookup on open()

Note You need to log in before you can comment on or make changes to this bug.