Bug 15715 - vmscan: underflow for get_scan_ratio
vmscan: underflow for get_scan_ratio
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-07 20:40 UTC by Rafael J. Wysocki
Modified: 2010-04-08 20:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.34-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-04-07 20:40:44 UTC
Subject    : [PATCH]vmscan: handle underflow for get_scan_ratio
Submitter  : Shaohua Li <shaohua.li@intel.com>
Date       : 2010-03-30 5:53
Message-ID : 20100330055304.GA2983@sli10-desk.sh.intel.com
References : http://marc.info/?l=linux-kernel&m=126992842105754&w=4
Handled-By : KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
Handled-By : Wu Fengguang <fengguang.wu@intel.com>

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 84b18490d1f1bc7ed5095c929f78bc002eb70f26
Author: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
Date:   Fri Mar 5 13:41:47 2010 -0800

    vmscan: get_scan_ratio() cleanup

    Signed-off-by: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
    Reviewed-by: Rik van Riel <riel@redhat.com>
    Reviewed-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
    Reviewed-by: Minchan Kim <minchan.kim@gmail.com>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

First-Bad-Commit : 84b18490d1f1bc7ed5095c929f78bc002eb70f26
Comment 1 Rafael J. Wysocki 2010-04-08 20:04:37 UTC
On Thursday 08 April 2010, Linus Torvalds wrote:
> 
> On Wed, 7 Apr 2010, Rafael J. Wysocki wrote:
> >
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.33.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15715
> > Subject		: vmscan: underflow for get_scan_ratio
> > Submitter	: Shaohua Li <shaohua.li@intel.com>
> > Date		: 2010-03-30 5:53 (9 days old)
> > First-Bad-Commit: http://git.kernel.org/git/linus/84b18490d1f1bc7ed5095c929f78bc002eb70f26
> > Message-ID	: <20100330055304.GA2983@sli10-desk.sh.intel.com>
> > References	: http://marc.info/?l=linux-kernel&m=126992842105754&w=4
> > Handled-By	: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
> > 		  Wu Fengguang <fengguang.wu@intel.com>
> 
> Reverted by commit d6da1a5abc2bf3a06a5bda08e0f6833409234666

Note You need to log in before you can comment on or make changes to this bug.