Bug 15713 - hackbench regression due to commit 9dfc6e68bfe6e
hackbench regression due to commit 9dfc6e68bfe6e
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Slab Allocator
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-07 20:31 UTC by Rafael J. Wysocki
Modified: 2010-06-13 17:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.34-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-04-07 20:31:49 UTC
Subject    : hackbench regression due to commit 9dfc6e68bfe6e
Submitter  : Alex Shi <alex.shi@intel.com>
Date       : 2010-03-25 8:40
Message-ID : 1269506457.4513.141.camel@alexs-hp.sh.intel.com
References : http://marc.info/?l=linux-kernel&m=126950632920682&w=4
Handled-By : Christoph Lameter <cl@linux-foundation.org>
Handled-By : Pekka Enberg <penberg@cs.helsinki.fi>

This entry is being used for tracking a regression from 2.6..  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 9dfc6e68bfe6ee452efb1a4e9ca26a9007f2b864
Author: Christoph Lameter <cl@linux-foundation.org>
Date:   Fri Dec 18 16:26:20 2009 -0600

    SLUB: Use this_cpu operations in slub

First-Bad-Commit : 9dfc6e68bfe6ee452efb1a4e9ca26a9007f2b864
Comment 1 Alex Shi 2010-05-05 08:47:46 UTC
The problem still exist on the orignal machine.
Comment 2 Rafael J. Wysocki 2010-06-13 17:28:12 UTC
On Sunday, June 13, 2010, Pekka Enberg wrote:
> On Sun, Jun 13, 2010 at 5:48 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.33 and 2.6.34.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.33 and 2.6.34.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=15713
> > Subject         : hackbench regression due to commit 9dfc6e68bfe6e
> > Submitter       : Alex Shi <alex.shi@intel.com>
> > Date            : 2010-03-25 8:40 (81 days old)
> 
> Fixed by:
> 
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=73367bd8eef4f4eb311005886aaa916013073265
> 
> in 2.6.35-rc1 and the commit is tagged for stable.

Note You need to log in before you can comment on or make changes to this bug.