Bug 15702 - fn keys don't work on vaio vgn-bx296xp
Summary: fn keys don't work on vaio vgn-bx296xp
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Platform (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Mattia Dongili
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-05 23:37 UTC by Teej
Modified: 2013-12-10 18:19 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: No


Attachments

Description Teej 2010-04-05 23:37:06 UTC
This bug was originally reported in Ubuntu at Launchpad https://bugs.launchpad.net/ubuntu/+source/linux/+bug/173366

" None of hotkeys of the sony vaio VGN-BX296XP seem to work apart from the mute button (which seems to be hw implemented).
 I contacted the developer of the sony_laptop module and he replied that my laptop seems to be using the GHKE method.
 The dmesg output shows the same scan code for ALL keys:

Use 'setkeycodes e075 <keycode>' to make it known.
[Unknown key released (translated set 2, code 0xf5 on isa0060/serio0)."

The problem is that every non-working FN-hotkey gives the same scancode, which suggests it could be kernel related.

Thank you.
Comment 1 heinjan 2010-04-06 21:06:05 UTC
There is a userspace utility fsfn which somehow captures the FN keypresses.
http://developer.berlios.de/bugs/?group_id=4604

Source code is browsable at:
http://svn.berlios.de/wsvn/fsfn/trunk/fsfn/src/#_trunk_fsfn_src_

The GHKE ACPI method used (>2 years ago) to work for the FN-keys in the vanilla kernel. If I read http://www.mail-archive.com/linux-acpi@vger.kernel.org/msg04257.html it seems this was the case when sony_acpi.c was still in use.

Note You need to log in before you can comment on or make changes to this bug.