Bug 15699 - rt2500usb driver cannot remain connected
rt2500usb driver cannot remain connected
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-04-05 19:30 UTC by jcallen
Modified: 2010-10-28 23:32 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34-rc3-00191-gdb217de
Tree: Mainline
Regression: Yes


Attachments

Description jcallen 2010-04-05 19:30:39 UTC
In 2.6.32 (and earlier), I was able to use the rt2500usb driver with my D-Link DWL-G122 wireless NIC (ID 2001:3c00 "D-Link Corp. [hex] DWL-G122 802.11g rev. B1 [ralink]").  Now, with 2.6.34-rc3-00191-gdb217de, once I get an IP address via dhcpcd, it immediately looses the connection, with the following message repeated in the syslog:

phy0 -> rt2500usb_set_device_state: Error - Device failed to enter state 3 (-16).
Comment 1 John W. Linville 2010-04-05 20:08:07 UTC
Any chance I could talk you into a git bisect? :-)
Comment 2 Ivo van Doorn 2010-04-05 20:23:21 UTC
Instead try:

iwconfig wlan0 power off

to disable power saving.
Comment 3 jcallen 2010-04-05 20:47:36 UTC
(In reply to comment #1)
> Any chance I could talk you into a git bisect? :-)
I haven't gotten a chance to do so yet, but I am able to do a bisect, if needed :)

(In reply to comment #2)
> Instead try:
> 
> iwconfig wlan0 power off
> 
> to disable power saving.

I've tried that, and it seems to be working now
Comment 4 Ivo van Doorn 2010-04-05 21:32:55 UTC
ok, no bisect needed then. Patches to fix this issue are on the way. :)

John, the patches which fix this are part of GertJans patch series:
http://permalink.gmane.org/gmane.linux.kernel.wireless.general/48736
Comment 5 Rafael J. Wysocki 2010-04-06 18:17:03 UTC
Handled-By : Ivo van Doorn <IvDoorn@gmail.com>
Comment 6 Rafael J. Wysocki 2010-04-09 19:53:09 UTC
On Friday 09 April 2010, Gertjan van Wingerde wrote:
> On 04/09/10 00:54, Rafael J. Wysocki wrote:
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15699
> > Subject		: rt2500usb driver cannot remain connected
> > Submitter	:  <abcd@gentoo.org>
> > Date		: 2010-04-05 19:30 (4 days old)
> > Handled-By	: Ivo van Doorn <IvDoorn@gmail.com>
> > 
> 
> This one ought to be fixed by commit 9e76ad2a27f592c1390248867391880c7efe78b3
> in Linus' tree.

Note You need to log in before you can comment on or make changes to this bug.