Bug 15695 - calling pm-suspend freezes system
calling pm-suspend freezes system
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 blocking
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 14885
  Show dependency treegraph
 
Reported: 2010-04-05 05:13 UTC by Werner Lemberg
Modified: 2010-10-28 23:31 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.34-rc3-7-pae (openSuSE 11.3 factory kernel)
Tree: Mainline
Regression: Yes


Attachments

Description Werner Lemberg 2010-04-05 05:13:18 UTC
[Dell Inspiron 6400; Intel 945GM]

The title says all.  The graphics system is switched to the console, then everything freezes without a trace in any of the log files.  This is the first kernel of the 2.6.34 series I'm able to boot.  Running 2.6.33-26 this problem doesn't exist.

Note that I *suspect* that it is a problem with the graphics driver (since usually pm-hibernate on 2.6.33 fails with similar symptoms).

Please tell me how to improve this report, if possible or necessary.
Comment 1 Werner Lemberg 2010-04-05 05:14:52 UTC
A typo: My current running system is 2.6.33-27.
Comment 2 Werner Lemberg 2010-04-06 06:15:27 UTC
BTW, I'm not even able to do a normal shut down; the last step, this is, switching off the display, fails.
Comment 3 Werner Lemberg 2010-05-06 04:52:00 UTC
Running 2.6.34-rc6-28-pae (from openSuSE's factory kernel), both pm-suspend and pm-hibernate work again.
Comment 4 Stefan Dirsch 2010-05-06 05:14:19 UTC
Yes, disabling FBC (frame buffer compression) on 945GM (upstream code change) fixed the issue.

Note You need to log in before you can comment on or make changes to this bug.