Bug 15668 - start_kernel(): bug: interrupts were enabled early
start_kernel(): bug: interrupts were enabled early
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: ARM
All Linux
: P1 normal
Assigned To: linux-arm-kernel@lists.arm.linux.org.uk
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-04-01 16:31 UTC by Maciej Rutecki
Modified: 2010-04-21 05:02 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.34-rc
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-04-01 16:31:15 UTC
Subject    : start_kernel(): bug: interrupts were enabled early
Submitter  : Rabin Vincent <rabin@rab.in>
Date       : 2010-03-25 19:53
Message-ID : 20100325194100.GA2364@debian
References : http://marc.info/?l=linux-kernel&m=126954607216519&w=2

This entry is being used for tracking a regression from 2.6.33.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 773e3eb7b81e5ba13b5155dfb3bb75b8ce37f8f9
  Author: Yinghai Lu <yinghai@kernel.org>
  Date:   Wed Feb 10 01:20:33 2010 -0800

      init: Move radix_tree_init() early

      Prepare for using radix trees in early_irq_init().

      Signed-off-by: Yinghai Lu <yinghai@kernel.org>
      LKML-Reference: <1265793639-15071-30-git-send-email-yinghai@kernel.org>
      Signed-off-by: H. Peter Anvin <hpa@zytor.com>

First-Bad-Commit : 773e3eb7b81e5ba13b5155dfb3bb75b8ce37f8f9
Comment 1 Kevin Hilman 2010-04-07 23:17:48 UTC
Proposed patch on LKML: http://lkml.org/lkml/2010/4/7/301

Tested on TI OMAP3 platform (ARM Cortex A8)
Comment 2 Rafael J. Wysocki 2010-04-21 04:59:36 UTC
On Tuesday 20 April 2010, Rabin Vincent wrote:
> On Tue, Apr 20, 2010 at 05:19:21AM +0200, Rafael J. Wysocki wrote:
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15668
> > Subject		: start_kernel(): bug: interrupts were enabled early
> > Submitter	: Rabin Vincent <rabin@rab.in>
> > Date		: 2010-03-25 19:53 (26 days old)
> > First-Bad-Commit: http://kernel.org/git/linus/773e3eb7b81e5ba13b5155dfb3bb75b8ce37f8f9
> > Message-ID	: <20100325194100.GA2364@debian>
> > References	: http://marc.info/?l=linux-kernel&m=126954607216519&w=2
> 
> This was fixed by 3eac4abaa69949af0e2f64e5c55ee8a22bbdd3e7 ("rwsem
> generic spinlock: use IRQ save/restore spinlocks").

Note You need to log in before you can comment on or make changes to this bug.