Bug 15631 - Brightness function is unresponsive on a HP DV3-2105TU laptop
Brightness function is unresponsive on a HP DV3-2105TU laptop
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2010-03-25 22:03 UTC by Michael
Modified: 2013-04-09 06:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32-17-generic
Tree: Mainline
Regression: No


Attachments
output of acpidump (186.17 KB, text/plain)
2010-03-26 05:55 UTC, Michael
Details

Description Michael 2010-03-25 22:03:33 UTC
Screen brightness is unresponsive to Fn+F7 and Fn+F8 key presses, however the values in the following paths do change accordingly:

/proc/acpi/video/OVGA/DD03/brightness
/sys/class/backlight/acpi_video0/brightness

I found an error message in /var/log/messages which may be a bug in the kernel module drivers/acpi/video.ko

[Firmware Bug]: ACPI: ACPI brightness control misses _BQC function

The laptop uses Intel GMA 4500MHD.
Please advise what information / output you require to debug this issue.
Comment 1 Zhang Rui 2010-03-26 02:22:42 UTC
please attach the acpidump output of this laptop.
Comment 2 Michael 2010-03-26 05:55:58 UTC
Created attachment 25720 [details]
output of acpidump
Comment 3 Zhang Rui 2010-03-29 07:31:57 UTC
please set CONFIG_ACPI_WMI and see if it helps.
Comment 4 Michael 2010-03-29 08:29:07 UTC
(In reply to comment #3)
> please set CONFIG_ACPI_WMI and see if it helps.

In the current (Ubuntu 2.6.32-17-generic) kernel it's already set:
CONFIG_ACPI_WMI=y


I'm not sure if this will help, but I had a look in the kernel source and found comments which may possibly be related to the "ACPI brightness control misses _BQC function" message I get in dmesg.
In drivers/acpi/video.c there is a comment regarding _BCQ as opposed to _BQC which says:

/* Some buggy BIOS uses _BCQ instead of _BQC */

which appears in the acpi_video_device_cap struct.

Could it be likely this BIOS may be doing similar?
Comment 5 Michael 2010-05-08 03:08:02 UTC
My current kernel is now 2.6.32-22-generic. Unfortunately the problem remains. Is there an update to this problem? It's been a while.
Comment 6 Michael 2010-06-04 04:43:58 UTC
I found the fix here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/568611/comments/11

Technically it addressed a fault with brightness functionality for a Dell Studio 1558, however once I installed the two .deb files as directed (and rebooted), the brightness function worked.

Kamal stated this was a preliminary test fix. It'd be good to have it progress to be integrated with the next kernel release. As he suggested, it's for '...Dell Studios or any other i915-based systems."
Comment 7 Michael 2010-06-04 04:46:13 UTC
On 2nd thought, since he released 3 patches, I'll mark this as RESOLVED PATCH_ALREADY_AVAILABLE

Note You need to log in before you can comment on or make changes to this bug.