Bug 15598 - i915 - gma-hd - video output slows down after suspend/resume on corei5-661
i915 - gma-hd - video output slows down after suspend/resume on corei5-661
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 14885
  Show dependency treegraph
 
Reported: 2010-03-21 20:36 UTC by lethalwp
Modified: 2010-03-29 19:33 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.34-rc1-next-20100318+
Tree: Mainline
Regression: Yes


Attachments

Description lethalwp 2010-03-21 20:36:59 UTC
when i suspend my computer to ram & resume, the video slows down to a point that fullhd movies can't be played in realtime anymore.

This happens all the time on kernel 2.6.34-rc1-next-20100318+, 2.6.33.1-fc13, but happened only(?) 2 times out of 30 tests on 2.6.32.9-70.fc12


my test benchmark is:
mplayer /directories/MVI_3080.MOV -benchmark -nosound -fs
(the movie is about 19 seconds in time)

which plays the file in ~9.5 seconds on a fresh boot + startx,
after a suspend, it plays the file in ~20seconds.

when i ommit the video output (-vo null), the results are identical before and after.


It looks like the suspend downclocks the gpu & doesn't reset the clock after a resume, but i don't know how to confirm this?


The weird part was on the 2.6.32.9fc12 kernel: after the resume, the video played fine a couple of times, before playing slower, and right after (no suspend/resume in between, just re-playing), it played back on full speed. I still tagged this as regression because this issue appears everytime on the higher kernels tried.


dmesg doesn't show anything special concerning gpu


cpufreq isn't loaded, because of an actual acpi problem, but the i7z tool does show frequency changes. This does not change the -vo null benchmark results so i don't think it's related.


My X version:
xorg-x11-drv-intel-2.10.0-4.fc13.x86_64
xorg-x11-server-common-1.7.99.901-8.20100223.fc13.x86_64

My motherboard:
Asus-p7h55d-v-evo with a corei5-661 cpu
Comment 1 lethalwp 2010-03-29 18:35:56 UTC
Is there something i can do to debug this problem better ?
Comment 2 lethalwp 2010-03-29 19:04:48 UTC
after my last system update, it looks like i'm unable to reproduce it? Could be a fixed xorg issue & not module.

Closing this issue for now

Note You need to log in before you can comment on or make changes to this bug.