Bug 15585 - [Bisected Regression in 2.6.32.8] i915 with KMS enabled causes memorycorruption when resuming from suspend-to-disk
[Bisected Regression in 2.6.32.8] i915 with KMS enabled causes memorycorrupti...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: Chris Wilson
:
Depends on:
Blocks: 7216 14885
  Show dependency treegraph
 
Reported: 2010-03-19 19:26 UTC by Maciej Rutecki
Modified: 2010-10-28 23:31 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.32.8
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-03-19 19:26:43 UTC
Subject    : [Bisected Regression in 2.6.32.8] i915 with KMS enabled causes memorycorruption when resuming from suspend-to-disk
Submitter  : "M. Vefa Bicakci" <bicave@superonline.com>
Date       : 2010-03-13 5:11
Message-ID : 4B9B1E8F.5090806@superonline.com
References : http://marc.info/?l=linux-kernel&m=126845754409543&w=2

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit d8e0902806c0bd2ccc4f6a267ff52565a3ec933b
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Wed Jan 27 13:36:32 2010 +0000

    drm/i915: Selectively enable self-reclaim

First-Bad-Commit : d8e0902806c0bd2ccc4f6a267ff52565a3ec933b
Comment 1 Rafael J. Wysocki 2010-04-11 20:13:30 UTC
On Sunday 11 April 2010, M. Vefa Bicakci wrote:
> On 08/04/10 07:04 PM, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.32 and 2.6.33.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.32 and 2.6.33.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15585
> > Subject		: [Bisected Regression in 2.6.32.8] i915 with KMS enabled causes memorycorruption when resuming from suspend-to-disk
> > Submitter	: M. Vefa Bicakci <bicave@superonline.com>
> > Date		: 2010-03-13 5:11 (27 days old)
> 
> I tested vanilla 2.6.33.2 and 2.6.34-rc3-git10, and unfortunately
> both of them *have* this issue. So it looks like the issue has not
> been resolved yet. Please keep this regression in the list of known
> regressions.
> 
> Just to let you know: I am currently running 2.6.33.2 with the above-
> mentioned commit reverted, and hibernate-thaw cycles work properly.
Comment 2 Jesse Barnes 2010-07-23 19:40:49 UTC
Chris, this one is fixed now, right?
Comment 3 Chris Wilson 2010-07-23 21:15:25 UTC
Yes after Linus' second patch the storm has quietened down but we nobody has yet managed to explain why...
Comment 4 Chris Wilson 2010-07-23 21:16:36 UTC
With great power, comes great responsibility...
Comment 5 M. Vefa Bicakci 2010-07-23 21:17:13 UTC
Hello,

Yes, this is fixed with the following two commits by Linus:

985b823b919273fe1327d56d2196b4f92e5d0fae
cd9f040df6ce46573760a507cb88192d05d27d86

Sorry for not updating the bug report.

Regards,

M. Vefa Bicakci

Note You need to log in before you can comment on or make changes to this bug.