Bug 15575 - Netbook Philco PHN 10108 doesn't supported by kernel to change LCD brightness level
Netbook Philco PHN 10108 doesn't supported by kernel to change LCD brightness...
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Platform_x86
All Linux
: P1 normal
Assigned To: drivers_platform_x86@kernel-bugs.osdl.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2010-03-18 23:20 UTC by Eriberto
Modified: 2013-12-10 18:16 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.34-rc1-git6
Tree: Mainline
Regression: No


Attachments
More informations. (347.86 KB, application/octet-stream)
2010-03-18 23:22 UTC, Eriberto
Details
lshw (15.57 KB, application/octet-stream)
2010-03-18 23:24 UTC, Eriberto
Details
acpidump (89.72 KB, application/octet-stream)
2010-03-18 23:27 UTC, Eriberto
Details
hwinfo (347.86 KB, application/octet-stream)
2010-03-18 23:28 UTC, Eriberto
Details
xrandr --verbose (3.61 KB, application/octet-stream)
2010-03-19 02:55 UTC, Eriberto
Details
Native backlight support for Intel (11.27 KB, patch)
2010-04-01 20:43 UTC, Matthew Garrett
Details | Diff

Description Eriberto 2010-03-18 23:20:07 UTC
Hi developers,

When can't change the LCD brightness in my netboot. It works fine in native netbook's SO (Windows 7 Home Starter).

Some informations:

cygnus:~# cat /proc/acpi/video/IGD/LCD/brightness
<not supported>

cygnus:~# ls -l /sys/class/backlight/
total 0

cygnus:~# uname -a
Linux cygnus 2.6.34-rc1-git6 #1 SMP Thu Mar 18 13:46:34 BRT 2010 i686 GNU/Linux

cygnus:~# cat /etc/debian_version
squeeze/sid

cygnus:~# lsmod |grep video
uvcvideo               44183  0
videodev               26658  1 uvcvideo
v4l1_compat            10354  2 uvcvideo,videodev
i2c_core               12406  6 i915,drm_kms_helper,drm,i2c_algo_bit,videodev,i2c_i801
video                  14805  1 i915
output                  1196  1 video
usbcore                99096  5 uvcvideo,usb_storage,uhci_hcd,ehci_hcd
thermal_sys             9522  4 processor,video,thermal,fan

cygnus:~# hwinfo --monitor
26: None 00.0: 10002 LCD Monitor
  [Created at monitor.95]
  Unique ID: rdCR.98oPz6MbmnE
  Hardware Class: monitor
  Model: "CPT LCD Monitor"
  Vendor: CPT "CPT"
  Device: eisa 0x04c4
  Resolution: 1024x600@60Hz
  Size: 222x130 mm
  Detailed Timings #0:
     Resolution: 1024x600
     Horizontal: 1024 1072 1104 1200 (+48 +80 +176) -hsync
       Vertical:  600  603  609  625 (+3 +9 +25) -vsync
    Frequencies: 45.00 MHz, 37.50 kHz, 60.00 Hz
  Config Status: cfg=new, avail=yes, need=no, active=unknown


Other informations are attached.

Thanks in advance.

Regards,

Eriberto - Brazil
Comment 1 Eriberto 2010-03-18 23:22:39 UTC
Created attachment 25596 [details]
More informations.
Comment 2 Eriberto 2010-03-18 23:24:23 UTC
Created attachment 25597 [details]
lshw
Comment 3 Eriberto 2010-03-18 23:27:58 UTC
Created attachment 25598 [details]
acpidump
Comment 4 Eriberto 2010-03-18 23:28:55 UTC
Created attachment 25599 [details]
hwinfo
Comment 5 Zhang Rui 2010-03-19 02:35:41 UTC
the backlight is not controlled via ACPI, i.e. no _BCM/_BCL/_BQC methods available.

can you change the backlight via xrandr?
please attach the full dmesg output of xrandr --verbose
Comment 6 Eriberto 2010-03-19 02:55:31 UTC
Created attachment 25603 [details]
xrandr --verbose
Comment 7 Eriberto 2010-03-19 03:01:34 UTC
I can't control via xrandr. File attached.
Comment 8 Zhang Rui 2010-03-19 03:10:01 UTC
This is not a Linux/ACPI bug because the backlight is not controlled via ACPI.

IMO, the problem is that the graphics driver fully rely on the backlight sysfs I/F, and doesn't support the native backlight switching any more.

Matthew wrote a patch to fix this, but I don't know the current status.
Comment 9 Eriberto 2010-03-19 03:18:44 UTC
Zhang, Must I wait a reply from Intel team?
Comment 10 Zhang Rui 2010-03-19 03:23:11 UTC
let's wait for Matthew's comments first. :p
Comment 11 Eriberto 2010-03-19 03:30:17 UTC
Ok Zhang. Thanks a lot for your help. I will wait. Bye!
Comment 12 Eriberto 2010-03-19 15:48:29 UTC
Opsss... In my original message: 's/When can't change the LCD brightness/I can't change the LCD brightness/'

:-)
Comment 13 Matthew Garrett 2010-04-01 20:43:46 UTC
Created attachment 25804 [details]
Native backlight support for Intel

This adds native backlight support for Intel. It's against drm-intel, so will probably only apply to 2.6.34-rc kernels. The backlight type support really needs to go upstream before this is mergable.
Comment 14 Jesse Barnes 2010-07-23 19:34:03 UTC
Dupe of https://bugs.freedesktop.org/show_bug.cgi?id=26664, closing.
Comment 15 Jonathan Nieder 2012-05-14 21:19:31 UTC
https://bugs.freedesktop.org/26664 says:

| Should be fixed by building the upstream samsung-laptop drivers.

Unfortunately, Eriberto's machine is from Philco, not Samsung.
Comment 16 Daniel Vetter 2012-05-19 22:56:12 UTC
Missing backlight driver is something for the acpi guys to beat their head against.
Comment 17 Jonathan Nieder 2012-05-19 23:02:25 UTC
From comment #8, 2010:

| This is not a Linux/ACPI bug because the backlight is not controlled via ACPI.
|
| IMO, the problem is that the graphics driver fully rely on the backlight sysfs
| I/F, and doesn't support the native backlight switching any more.
|
| Matthew wrote a patch to fix this, but I don't know the current status.

Assigning to platform-driver-x86.

Note You need to log in before you can comment on or make changes to this bug.