Bug 15570 - System powers off instead of suspending (MSI K8T Neo)
System powers off instead of suspending (MSI K8T Neo)
Status: CLOSED INVALID
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
https://bugs.launchpad.net/ubuntu/+so...
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-03-18 02:02 UTC by unggnu
Modified: 2010-03-20 13:25 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33
Tree: Mainline
Regression: Yes


Attachments
script to get acpi tables (406 bytes, application/octet-stream)
2010-03-18 06:45 UTC, Zhang Rui
Details
acpi tables (6.35 KB, application/x-bzip)
2010-03-18 09:44 UTC, unggnu
Details
Dmesg after suspend with pm_test (12.95 KB, text/plain)
2010-03-18 09:50 UTC, unggnu
Details

Description unggnu 2010-03-18 02:02:55 UTC
I am using current Ubuntu 10.10 testing branch.
If I suspend the system everything seems to work fine but as soon as I power it on again the system boots like after a normal shutdown.

The same happens with the mainline Kernel 2.6.33 but it works fine with Windows XP.

Motherboard: MSI K8T Neo
Chipset:  Via K8T800
Graphic: Radeon 9800 XT

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
Date: Wed Mar 17 22:01:53 2010
DistroRelease: Ubuntu 10.04
MachineType: MSI MS-6702
Package: linux-image-2.6.32-16-generic 2.6.32-16.25
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=3c0dcd65-8c85-4908-a73e-7ec4b9a04f74 ro quiet splash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: No
RelatedPackageVersions: linux-firmware 1.32
Reproducible: Yes
RfKill:

SourcePackage: linux
TestedUpstream: Yes
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 04/02/01
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: Version 07.00T
dmi.board.name: MS-6702
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: 0123ABC
dmi.chassis.type: 3
dmi.chassis.vendor: Uknown Chassis Manufacture
dmi.chassis.version: Version 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrVersion07.00T:bd04/02/01:svnMSI:pnMS-6702:pvr1.0:rvnMSI:rnMS-6702:rvr1.0:cvnUknownChassisManufacture:ct3:cvrVersion1.00:
dmi.product.name: MS-6702
dmi.product.version: 1.0
dmi.sys.vendor: MSI

Dmesg: http://launchpadlibrarian.net/41166781/BootDmesg.txt
Lspci: http://launchpadlibrarian.net/41166787/Lspci.txt

More files are available in the Launchpad bug report. Let me know if anything else is needed.
Comment 1 Zhang Rui 2010-03-18 06:45:20 UTC
Created attachment 25576 [details]
script to get acpi tables

please use this script as root user to get all the acpi tables of your laptop.
Comment 2 Zhang Rui 2010-03-18 06:49:20 UTC
please build a kernel with CONFIG_PM_DEBUG=y, CONFIG_ACPI_DEBUG=y and run the following test,
1. echo core > /sys/power/pm_test
2. echo mem > /sys/power/state
does the system resume back after about 10 seconds?
Comment 3 unggnu 2010-03-18 09:44:53 UTC
Created attachment 25587 [details]
acpi tables
Comment 4 unggnu 2010-03-18 09:48:39 UTC
I have used the mainline kernel 2.6.33 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33/ and it resumed after about 10 seconds with the described method.
But it seems to be only standby or something like that since the fan never stopped rotating.
Comment 5 unggnu 2010-03-18 09:50:18 UTC
Created attachment 25588 [details]
Dmesg after suspend with pm_test
Comment 6 unggnu 2010-03-18 09:58:43 UTC
Btw. just for the records with the Ubuntu Kernel 2.6.32 I got this message on startup in dmesg:
[   18.066808] ACPI: I/O resource vt596_smbus [0x400-0x407] conflicts with ACPI region SMOV [0x400-0x406]
Comment 7 Rafael J. Wysocki 2010-03-19 19:21:22 UTC
What do you normally do to suspend it?
Comment 8 unggnu 2010-03-19 19:29:36 UTC
Thanks for your reply. I use the Gnome Suspend function but the same happens if I run "sudo pm-suspend" in console.
Comment 9 Rafael J. Wysocki 2010-03-19 19:31:04 UTC
What kind of graphics hardware/driver is used?
Comment 10 unggnu 2010-03-19 19:43:35 UTC
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc R360 NJ [Radeon 9800 XT] [1002:4e4a]

The open radeon driver with KMS is used.
Comment 11 unggnu 2010-03-19 19:50:17 UTC
Ok, it seems that according to another bug report about this pc suspend works fine with 2.6.31 and 2.6.28 Kernel of Ubuntu Karmic and Jaunty except of some graphic glitches.
So it seems to be a regression. I have to recheck it with a Karmic Live CD though.
Comment 12 Rafael J. Wysocki 2010-03-19 19:57:40 UTC
Would it be possible to try without KMS and/or from runlevel 3 (ie. no X)?
Comment 13 unggnu 2010-03-19 22:39:29 UTC
Ok, I have the same problem with the Karmic Live CD. Windows XP still works fine so it shouldn't be a hardware error.

The same happens with radeon.modeset=0 and without X (I suppose recovery mode with KMS should be similar).
Comment 14 Rafael J. Wysocki 2010-03-19 22:44:57 UTC
In that case there seems to be a platform (BIOS/firmware) problem with the box we're not aware how to handle at the moment.

We're in the process of adding some ACPI-related fixes to the kernel that in theory might be related to the issue with your system.

Anyway, if that is a regression, it would be very helpful if you could identify the change that caused the failure to start appearing (eg. by means of bisection).
Comment 15 unggnu 2010-03-20 11:07:15 UTC
After removing a USB voice communication device suspend seems to work fine at least with Ubuntu Lucid. It also works with the mainline Kernel but there are some graphical problems but this has something to do with radeon or similar since the system shuts down after ctrl + alt + del and or on acpi events.

I don't know why Windows XP hasn't this problem but since suspend works without the SideWinder Game Voice I am closing this report. Sorry for taking your time.
Comment 16 Rafael J. Wysocki 2010-03-20 13:25:33 UTC
No problem.

Note You need to log in before you can comment on or make changes to this bug.